Need Help! '03 7.3 Starts/ Nothing at pedal and gauges won't move - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 09-18-2012, 05:51 PM Thread Starter
Member
 
Dustin34520's Avatar
 
Join Date: Mar 2012
Location: Nashville, TN
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Need Help! '03 7.3 Starts/ Nothing at pedal and gauges won't move

Thanks in advance for the help!

Will move at idle only. No response at pedal and gauges. Dash only lights when I turn on headlights, no warning lights at all. What did I fry?

2003 F350 CCSB 7.3, Stock as of now
Dustin34520 is offline  
post #2 of 6 Old 09-18-2012, 06:10 PM
Compression Ignition Addict
 
jesilvas's Avatar
 
Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,148
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 27 Times in 25 Posts
Feedback Score: 0 reviews
Did you check all the fuses?
What were you doing to fry something?
More info.



2000 F-350 Lariat Super Duty, Dually, CCLB, 7.3L
4R100, 2wd
330,000 + miles
jesilvas is offline  
post #3 of 6 Old 09-18-2012, 06:28 PM Thread Starter
Member
 
Dustin34520's Avatar
 
Join Date: Mar 2012
Location: Nashville, TN
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by jesilvas View Post
Did you check all the fuses?
What were you doing to fry something?
More info.
No, I didn't check all the fuses yet. I was at the CVS with my three and one year old. I had to get them back home for bed. CVS is close so we walked to the house. My truck is still there. Got to the store just fine. Went to leave, put it in drive and zero throttle response. Look at my dash and the gauges weren't moving either. The truck is stock. I can handle a fuse, but I think it's something worse.

2003 F350 CCSB 7.3, Stock as of now
Dustin34520 is offline  
post #4 of 6 Old 09-18-2012, 07:28 PM Thread Starter
Member
 
Dustin34520's Avatar
 
Join Date: Mar 2012
Location: Nashville, TN
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It was a 10 amp mini fuse, Thank you Jesus!! Should have looked into it a little deeper but I thought there was a bigger issue. Thanks

2003 F350 CCSB 7.3, Stock as of now
Dustin34520 is offline  
post #5 of 6 Old 09-19-2012, 06:06 AM
Compression Ignition Addict
 
Join Date: Dec 2007
Posts: 6,130
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 63 Post(s)
Thanks: 7
Thanked 221 Times in 212 Posts
Feedback Score: 3 reviews
You actually DO have another issue, and it's gonna happen again if you don't fix it


Have a look at this -> https://b7445ba3-a-62cb3a1a-s-sites....attredirects=0
NoRalPh is offline  
post #6 of 6 Old 09-24-2012, 03:19 PM Thread Starter
Member
 
Dustin34520's Avatar
 
Join Date: Mar 2012
Location: Nashville, TN
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
[QUOTE=NoRalPh;3259042]You actually DO have another issue, and it's gonna happen again if you don't fix it

Man, you were right! I've been through about 4 fuses now. THANKS FOR THE HELP BROTHER!! -Dustin

2003 F350 CCSB 7.3, Stock as of now
Dustin34520 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome