7.3 in need of major help - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-17-2012, 08:49 AM
Compression Ignition Addict

 

Join Date: Jul 2009
Location: Lochbuie, Co
Posts: 1,176
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
7.3 in need of major help

Ok so my truck has decided to have a gremlin I or no one else has been able to figure out. I've searched the forums and found guys have had similar problems, but there was never a post saying how they fixed it. So my truck was having an issue building boost past 15 lbs. So after resealing the plenums and new bellowed uppipes. I found it was actually my 6 month old filter was clogged. Changed that to discover I had another issue. My truck will build boost to about 25 and once it shifts it will instantly drop to 15 and I can get anything more out of it. It only does this at full thouttle. If I go about half throuttle it will build boost fine but as soon as I push it to the floor it instantly drops to 15-17lbs. It will do this thru all the gears but 1st. My last pull about a month ago, I broke a driveshaft and didn't notice til I was driving home that my transmission wiring fell onto my front driveshaft. I repaired all the wires with solder and heat shrink.
Ok now for what I've tried t resolve the issue, there is new oil and filter, fuel filter, fuel pump, icp, ipr, map sensor and iat manifold sensor. I have swapted the throuttle postioning sensor and speed sensor off my brothers early 99 and tried a pcm out of a 2000. I have checked voltage to both the pedal and map sensor. We have hooked my truck up to a motus and watched the numbers. My oil pressure right around 2800-2900. I don't have a ebpv and the tube goin to the ebp sensor has been blown apart for close to a year now with no problem. I have not got any check engine lights this whole time. I have a pull Saturday and have to atleast hook to get 2nd in points this season so id like to get this figured out asap. Please help a follow 7.3 guy out.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-17-2012, 08:50 AM
Compression Ignition Addict

 

Join Date: Jul 2009
Location: Lochbuie, Co
Posts: 1,176
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
I also have a boost fooler from strictly I've adjusted and changed nothing.
Reply With Quote Quick reply to this message
  #3  
Old 09-17-2012, 08:52 AM
Compression Ignition Addict

 

Join Date: Jul 2009
Location: Lochbuie, Co
Posts: 1,176
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
The truck almost feels like its defueling but smokes like crazy when the boost drops. I have a fuel pressure gauge and I hol 65 at idil and around 40-45 wot
Reply With Quote Quick reply to this message
  #4  
Old 09-17-2012, 09:02 AM
Compression Ignition Addict

 

Join Date: Jul 2009
Location: Lochbuie, Co
Posts: 1,176
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
One more thing as I'm just trying to give as much info as possible. I hve tried both my chips nd ran ir without one and it doesn't change anything
Reply With Quote Quick reply to this message
  #5  
Old 09-18-2012, 04:28 AM
Compression Ignition Addict

 

Join Date: Jul 2009
Location: Lochbuie, Co
Posts: 1,176
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Morning bump
Reply With Quote Quick reply to this message
  #6  
Old 09-18-2012, 05:03 AM
Banned
 

Join Date: Sep 2008
Location: Fort Bragg, NC/Buff, NY/Midlothian, VA
Posts: 5,630
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
repost this into general discussion man... you aren't gonna get any hits in this section of the forum.

It def sounds like its defueling tho or limping out....
Reply With Quote Quick reply to this message
  #7  
Old 09-18-2012, 05:38 AM
Compression Ignition Addict

 

Join Date: Jul 2009
Location: Lochbuie, Co
Posts: 1,176
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Can a mod move this?
Reply With Quote Quick reply to this message
  #8  
Old 09-18-2012, 05:54 AM
Banned
 

Join Date: Sep 2008
Location: Fort Bragg, NC/Buff, NY/Midlothian, VA
Posts: 5,630
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
would probably be faster to just repost it
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:49 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors