Birth of a CPS problem? - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 10-15-2007, 08:51 PM Thread Starter
Compression Ignition Addict
 
Big Ol Big's Avatar
 
Join Date: Jul 2007
Location: Watson, La.
Posts: 209
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Birth of a CPS problem?

I have owned an 03 7.3 4x4 CC for about a month now (1st diesel owned). Friday evening, I'm sitting at a stop light on my way home from work and the truck just dies. No warnings, No signs, just smooth idle then DEAD. I'm thinking what the ! The truck starts right back up and runs fine the rest of the way home. I drove back and forth to work Saturday without a hitch. Then Sunday evening I'm driving home from work and encounter a repeat of Friday evening. Same scenario just different stop light. Truck fires right back up and runs great the rest of the way home. I drove the truck back and forth to town today and never missed a beat, ran like a top. Could this be the birth of a CPS problem or maybe something else? The truck has 82,000 miles on it if that matters. Any suggestions or ideas would be greatly appreciated.
Big Ol Big is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 10-15-2007, 11:47 PM
Powerstroke Techie


 
alabamafrog's Avatar
 
Join Date: Jun 2007
Location: Huntsville/Arab alabama
Posts: 3,578
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
A CPS costs about $20 now compared to around $180 last year and takes around 5 minutes to change so I say change it and if it still acts up then you have a spare CPS, if it fixes it then buy another one for a spare.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

“Government, even in its best state, is but a necessary evil; in its worst state, an intolerable one” (T Paine)
Government cannot give anyone anything without stealing it from someone else. (A Frog)


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
alabamafrog is offline  
post #3 of 3 Old 10-16-2007, 08:13 PM
Member
 
miron42069's Avatar
 
Join Date: Jul 2007
Location: Roy, Utah.
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
mine does this all the time, sometimes 7 times a day, sometimes once a week. been doing it for the past year, it always starts right back up. its done it a few times going like 25 mph coming up to a stop with my foot of the gas. sucks because i have no brakes or steering lol 99 7.3
.
miron42069 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome