Truck off and on goes into limp mode... - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 07-20-2012, 04:22 PM Thread Starter
Member
 
HawaiianPSD's Avatar
 
Join Date: Nov 2006
Location: Hilo, Hawaii
Posts: 77
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Truck off and on goes into limp mode...

Got a 01 w/ 140K. Problem started 2 days ago, truck stumbles and goes into limp mode. It clears itself up then runs fine for a second to 10-15 minutes or more then repeats. It kicks on SES light when in limp mode, when clear the light goes off. CPS is good and UVCH mod was done a year ago. Fuel filter changed every 10-15K miles. Friend of mine thought it could be algae build up in the tank and clogging in-tank filter, don't know. Pulled the wix fuel filter I just threw in a few hundred miles ago, looks good, slight sediment build up at bottom of bowl, didn't see algae. Got it drained and cleaned out, some algae appeared in catch bottle, thinking it came from the drain line, don't really know. I threw in some FPPF KILLEM recommended by the local petro place but cautious to take my truck anywhere with this limp mode problem



I read it could be accelarator pedal position sensor on a mechanic friends All Data program he has at his shop. What else would cause my truck to run fine then go into limp mode and vice versa? Any ideas guyz?

01 6 speed
AFE Stage II
4" DP to 5" Straight pipe
DP Tuner
6" on 35's
HawaiianPSD is offline  
post #2 of 3 Old 07-21-2012, 01:30 AM Thread Starter
Member
 
HawaiianPSD's Avatar
 
Join Date: Nov 2006
Location: Hilo, Hawaii
Posts: 77
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Shot in the dark... changed TPS, so far so good!

01 6 speed
AFE Stage II
4" DP to 5" Straight pipe
DP Tuner
6" on 35's
HawaiianPSD is offline  
post #3 of 3 Old 07-21-2012, 05:31 AM
Compression Ignition Addict
 
Turbostang500's Avatar
 
Join Date: Oct 2011
Location: Dover
Posts: 1,634
Thanks: 1
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Hopefully that works out for ya.

Remember, just because you did a UVCH mod, doesn't mean they aren't acting up now.

Lee

2000 F250 PSD SCSB 4X4 418k miles straight pipe gauges 2" leveling kit 315/75r16's
6637 with custom intake pipe. TS Performance 6 position chip!
[/URL]


Please don't confuse my attitude with my personality.. my personality is who I am,my attitude depends on who you are...
Turbostang500 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome