7.3 blowing whit smoke at start up, HELP!!! - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 07-05-2012, 10:57 AM Thread Starter
FEAGLEY 2010's Avatar
Join Date: Jul 2012
Posts: 63
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
7.3 blowing whit smoke at start up, HELP!!!

I have a 2000 f-250 superduty 7.3L, the guy I bought the truck from fixed the injectors that went out and replaced o-rings. Lately when I start it up it blows white smoke for a couple minutes. Then goes away. It doesn't loose power or sound like its killing its self like an injector is going out. Help me, thanks

Sent from my Desire HD using AutoGuide.Com Free App
FEAGLEY 2010 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome