Need help! 7.3 Acting up - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 06-03-2012, 12:11 PM Thread Starter Rookie
Join Date: Jun 2012
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Need help! 7.3 Acting up

I have an early 1999 F250 7.3 4x4 that is chipped, has exhaust, and a cai. My tranny is slipping 3rd gear so yesterday I went and but a bottle of Lucas No slip into it. Yes, it made a difference. But now When I went to drive my truck this morning I had no power, and more smoke then usual. I don't think this has any relavance. But I need some help. What causes more black smoke and power loss. I changed the fuel filter today, cleaned the air filter, and put fuel injector cleaner into the new filter. No difference at all.
99stroking is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome