Power surge/misfire and EBP sensor - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-12-2012, 10:26 PM
PMR = JUNK

 

Join Date: Nov 2007
Location: NW, Ohio
Posts: 11,189
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
Send a message via AIM to Jake Send a message via Yahoo to Jake
Power surge/misfire and EBP sensor

I've having a bit of an odd issue with my truck that i can't quite figure out. First off, around 1500 rpm i can feel the power of the engine surge a bit. Not really a misfire, just a rapid power surge. Not a huge one, but you can feel it. Mostly noticeable in 3rd gear after the converter locks driving through town at about 35-40 MPH.

Secondly, after running it hard, sometimes i get a miss at idle. Clears up as soon as i push the pedal. Does it in neutral/park and in gear. Otherwise, besides the power surge issue it runs fine, besides crap azz fuel mileage (15-16 if i BABY it, 13-14 normal driving), which brings me to my next question.

What exactly does the EBP sensor do, and what are normal readings for it? I have a hunch that maybe this has something to do with my issues, both the surge/misfire and piss poor fuel mileage. Key on engine off, the MAP reads 14.5 +/- whereas the EBP reads mid 20's. Id have to look at my data logs to find the exact number but regardless, that can't be right. I would think it should read either PSIG, which KOEO would be 0, or absolute, which would be 14.5 +/-.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-13-2012, 03:41 PM
PMR = JUNK

 

Join Date: Nov 2007
Location: NW, Ohio
Posts: 11,189
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
Send a message via AIM to Jake Send a message via Yahoo to Jake
Sunday
Reply With Quote Quick reply to this message
  #3  
Old 05-13-2012, 05:15 PM
Powerstroke Techie

 

Join Date: Oct 2007
Location: Saint Cloud, WI
Posts: 4,455
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Clean your ebp tube and sensor. If you have the sensor hanging by the wires, cleaned it should read really close to map and baro. If not then you should put a new one on. EBP is used for fueling along with the map even though the book doesn't say it's used for anything except for ebp valve monitoring.
Reply With Quote Quick reply to this message
  #4  
Old 05-13-2012, 05:19 PM
PMR = JUNK

 

Join Date: Nov 2007
Location: NW, Ohio
Posts: 11,189
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
Send a message via AIM to Jake Send a message via Yahoo to Jake
Think that will fix my issues? I'll give it a shot tomorrow if i have time and report back. I wonder why the book would lie like that.
Reply With Quote Quick reply to this message
  #5  
Old 05-13-2012, 05:42 PM
Powerstroke Techie

 

Join Date: Oct 2007
Location: Saint Cloud, WI
Posts: 4,455
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
That's where I would start. I've seen it before. I just looked up a 04 with a 6.0 and it doesn't say that it uses it for fueling in there either, but it does.
Reply With Quote Quick reply to this message
  #6  
Old 05-15-2012, 04:59 PM
PMR = JUNK

 

Join Date: Nov 2007
Location: NW, Ohio
Posts: 11,189
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
Send a message via AIM to Jake Send a message via Yahoo to Jake
Well, put a different MAP and EBP sensor on it, still reading the same as i told you on the phone zach, except now EBP reads 19.xx KOEO. Still at 12.2 for MAP. I'm almost wondering if something is screwy in my PCM. We are gonna put my buddy's PCM in when we get time. His is a manual trans but engine sensors should read the same.
Reply With Quote Quick reply to this message
  #7  
Old 05-16-2012, 06:13 PM
Powerstroke Techie

 

Join Date: Oct 2007
Location: Saint Cloud, WI
Posts: 4,455
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Hmm. that is interesting. I would suggest that you have a v-ref issue, but the baro reads normal. What's your icp voltage koeo (key on engine off)?
Reply With Quote Quick reply to this message
  #8  
Old 05-17-2012, 03:24 AM
PMR = JUNK

 

Join Date: Nov 2007
Location: NW, Ohio
Posts: 11,189
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
Send a message via AIM to Jake Send a message via Yahoo to Jake
Quote:
Originally Posted by forddieseldoctor View Post
Hmm. that is interesting. I would suggest that you have a v-ref issue, but the baro reads normal. What's your icp voltage koeo (key on engine off)?
What is v-ref? I'll check the ICP volts later today and report back.
Reply With Quote Quick reply to this message
  #9  
Old 05-17-2012, 03:34 AM
Compression Ignition Addict
 

Join Date: Jan 2012
Posts: 501
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
I was told I had an ebp issue as well I found a sensor or something unplugged at the front of my driver side valve cover right by the dip stick... Is that it my truck was throwing a P0472 code and through research I was told that it should be in close proximity of the map and anywhere between 14-17. I don't know where to monitor these things but any help would be greatly appreciated


Sent from my Autoguide iPhone app
Reply With Quote Quick reply to this message
  #10  
Old 05-17-2012, 03:36 AM
Compression Ignition Addict
 

Join Date: Jan 2012
Posts: 501
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
I was getting low boost on Vivian's looney I haven't hit that code again but boost seems low still no leaks but also at 25% throttle position I can de doing 65mph so I think that's the reason for my low boost.


Sent from my Autoguide iPhone app
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:24 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors