Service Engine Soon - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 04-30-2012, 07:27 AM Thread Starter
Member
 
Sgt. Stroker's Avatar
 
Join Date: Nov 2008
Location: Evansville, Indiana
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to Sgt. Stroker Send a message via Skype™ to Sgt. Stroker
Service Engine Soon

Maybe I am just paranoid but my SES light came on and everytime I freak. I was told by someone that it comes on for a oil change. I believe it only because I am close to my 5,000 oil change mark. I think I'm gonna use royal purple synthetic this summer. Love it in my axles. So my question here is why the SES light? Does my 99.5 powerstroke have a service engine light and a check engine?

When it cold out and I start it, it has a small puff of white smoke. Doesn't run rough and it drives fine. Plenty of power and response.

1999 F-250
TS 4 Pos Chip(50-75-100-140)
AFE air intake with K&N filter
5" Exhaust
3 Pillar pod (Pyro, EGT, Boost)
Sgt. Stroker is offline  
post #2 of 3 Old 04-30-2012, 07:36 AM
ADMIN AND TECH


 
SCUFFY828's Avatar
 
Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,316
Thanks: 0
Thanked 11 Times in 11 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
if youre running a chip of any kind ,and the light comes on under accel it will give a oil pressure code ,which actually is fairly normal , doesnt necesarily mean need an oil change , just means that when a chip is installed the injectors are needing more oil than the high pressure oil pump can keep up with and will throw the code p1211, and on some trucks a p1209 and p1211, it wont hurt anything just a fairly common situation

SCUFFY828@POWERSTROKE.ORG
ITS STOCK
SCUFFY828 is offline  
post #3 of 3 Old 04-30-2012, 08:51 AM Thread Starter
Member
 
Sgt. Stroker's Avatar
 
Join Date: Nov 2008
Location: Evansville, Indiana
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to Sgt. Stroker Send a message via Skype™ to Sgt. Stroker
I was acting stupid las week and drove it hard for a time or two. Only on the 100HP setting. The SES light is still on. It came on last time it was time for a oil change too...is my truck just that much smarter than I assume?

1999 F-250
TS 4 Pos Chip(50-75-100-140)
AFE air intake with K&N filter
5" Exhaust
3 Pillar pod (Pyro, EGT, Boost)
Sgt. Stroker is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome