any idea - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 02-26-2012, 09:56 AM Thread Starter Fanatic
Maxtorque's Avatar
Join Date: Feb 2007
Location: Feasterville PA
Posts: 103
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to Maxtorque
any idea

OK went out to start the truck. Stuck key in waited turned the key. Nothing its like someone pulled the battery. Turn the key back and remove and I hear a clicking noise from the fuse box. Pull the cover and its a relay clicking. Its the top relay on the left. Its a different shape than any other relay. Pull it and reinstall and clicking stops. Batteries are low on charge so charger is on. Could it be a low battery causing the problem. Figured it was a good place to start anyway. If anyone has any other ideas please let me know. Thanks Martin

2001 F-350 Crew Cab 4x4
4" Exhaust Straight
6 pos chip
foil delete
K&N filter
Auto meter gauges
1971 Super Sport Chevelle 496cid, 400, 4:10's

Drive it like you stole it...
When it breaks fix it!!!
Maxtorque is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome