7.3L not starting - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 02-12-2012, 03:54 PM Thread Starter
Member
 
RossWM's Avatar
 
Join Date: Jan 2012
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
7.3L not starting

so i went to work yesterday the truck was running fine and when i got off it wouldnt start, i had some trouble starting it in the cold before so i replaced the glow plugs and glow plug relay and its been running fine till now. I tried using starter fluid and couldnt get it to start but it sounds like it was having trouble turning over like the battery was dead so i tried to jump it, no luck
i've always had to crank it and unusual amount of time to start it so i'm thinking my starter has gone bad, does this sound like the most likely problem?
RossWM is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 02-12-2012, 04:08 PM
Compression Ignition Addict
 
jesilvas's Avatar
 
Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,148
Thanks: 0
Thanked 27 Times in 25 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Starter Fluid !
Check batteries, cables, connections, starter.
And I'd double check the GP and GPR for proper operation. Just cause it's new don't mean squat.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2000 F-350 Lariat Super Duty, Dually, CCLB, 7.3L
4R100, 2wd
330,000 + miles
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jesilvas is offline  
post #3 of 3 Old 02-17-2012, 01:38 AM Thread Starter
Member
 
RossWM's Avatar
 
Join Date: Jan 2012
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
it was the starter i took the starter to advanced they tested it and told me it was good but i went ahead and got a new one anyway and it fired right up.
RossWM is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome