worse engine miss after all new injectors - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 09-10-2007, 04:11 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2007
Location: north of detroit
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
worse engine miss after all new injectors

Hi. 1998 7.3, had a hard/no start cond. glow plugs & circuit were performing fine, checked hi press oil press, took too long to build enough pressure, replaced the hi pres. pump,& ICP regulator, problem was better but not fixed,& a slight engine miss, talked to other techs, suggested possible bad injector o rings, replace all injectors & o rings, now the miss is much more pronounced, the injectors are all plugged in, they all buzz test fine, I checked continuity up to & thru valve cover gaskets, Also the miss is pretty much gone with just a small amount of throttle or when dropped in gear, got any ideas?????
ddbob58 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 09-10-2007, 04:27 PM
BIG TRUCK, SMALL DRIVER
 
pipelayerjdh's Avatar
 
Join Date: Oct 2006
Location: Iva, SC
Posts: 5,877
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Have you changed the CPS and checked fuel pressure?

Derrick

My photobucket




'97 F-350 "FORDOR" 4X4 (Dually Conversion, Shackle Reversal, Technicooler , Auto Meter Gauges, 4" DIY Dual Exhaust w/ '08 tips, 4" DIY intake w/ AEM filter, Wicked Wheel 2, 360° thrust bearing, Homemade E-fuel conversion, Wildman Chip, 160cc DIY injectors , DIY IDM mod) 230K and counting...
pipelayerjdh is offline  
post #3 of 3 Old 09-10-2007, 05:51 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2007
Location: north of detroit
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I forget to say the CPS was changed 1st before anything, but the fuel press. hasn't been checked, where should it be, isn't it about 40psi??
ddbob58 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome