Loses throttle response - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 11-24-2011, 06:33 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2011
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Loses throttle response

My truck has started doing this thing where I'll just be going and it'll lose all throttle response ..it will idle just fine but I'll keep hitting the pedal and just nothing for a minute or so.and everytime it happens the check engine light comes on and as soon as it takes off again the light goes out and runs fine..
There's no real pattern to when it happens so I'm just confused all my fluid levels are up and right I haven't checked for any codes yet but I figured I ask you guys first what you thought.. Thanks
angus121 is offline  
post #2 of 4 Old 11-24-2011, 07:32 PM
aussie=effie
 
bob harris's Avatar
 
Join Date: Apr 2010
Location: melbourne, australia
Posts: 286
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
replace CPS and if that dont work your throttle pack
bob harris is offline  
post #3 of 4 Old 11-25-2011, 06:14 PM
Member
 
Join Date: Aug 2010
Location: Zanesville, Ohio
Posts: 66
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mine was doing the same thing. Started out to just randomly and one day it never came back lol. Replaced the whole pedal assembly and its been good ever since. If it stops working while you are moving the cruise control will still work.. Kinda sucks but it will get u home lol.
Lando302 is offline  
post #4 of 4 Old 07-13-2012, 01:25 PM
Powerstroke.org Rookie
 
Join Date: Jul 2012
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Angus,

Did you ever get it fixed?

I'm having the same issue in my 02 350...
Pinkdog is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome