Not panicking yet but my truck might have transformed into the Exxon Valdez - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-11-2011, 05:28 AM
Powerstroke.org Rookie
 

Join Date: Sep 2010
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Question Not panicking yet but my truck might have transformed into the Exxon Valdez

First off, just want to say how much use this sight has been as a resource and coupled with the sponsors it has been invaluable. Gentlemen & Ladies I thank you for the hours you have saved and the knowledge imparted.

So here's the problem.. Oil leak all of a sudden out of no where and it appears to be rather a large one.

Apologies for the long winded post..

A little truck info
2000 F250 4x4 (Crew cab, short bed (relevant? I doubt it..))
7.3 Powerstroke
204,000 miles

Mods/Updates
*** By previous owner ***
S&B Air Intake
Standard 3 gauges
Undetermined lift
T6 Chip
*Programming on it is wrong for the current setup of the truck, makes the truck downshift for no apparent reason. My assumption is that the previous owner had a different wheel/tire combo so it's behaving like it's meant to but doesn't realize the game has changed..there was also a program burnt onto the ?PCM? that I had re-set by the local dealership for $120 and 3 hours of life
There was a BTS Valve body that was apparently destroyed/holes in the wrong place when the transmission died..that's a whole different story..
**Above done by previous owner ***

HPX crossover
CCV turn around
Plenum inserts
New boots (except to/from intercooler)
Fuel regulator set to 65psi High-flow banjo bolts
Raptor - Lift Pump (Hate it, loud and it doesn't cut off like it should)
Transmission rebuilt at 201,000 after total destruction occurred
Diablo Predator - Don't like it at all and probably like it even less now..

Known issues
Slight shudder/skip when taking off
-re-greased spline didn't make a huge difference
Lift pump not cutting out after priming fuel bowl
- issue should cease when fuel bowl deleted?

Oil changed (dino) every 4k since I've had it.. previous owner said the same thing..


Does that give enough info?

The problem..
While all the mods have been happening, I removed the Diablo Predator 110HP program(or whatever you want to call it). Logic was that I wanted to see what the truck was doing without any external influence..

So after running it for a couple of weeks with no issue I decided (maybe with hindsight stupidly) to put the program back on, did that last night, went out for dinner, and when I walked back i saw a puddle of oil under the truck.

There have never been any leaks before so I assumed that it must've been the person who parked there before.. this morning there was a puddle of oil on the driveway.

Checked oil and it was low (Middle of the XXXXX marks) added oil, removed Predator programming and drove to work. Stopped half way - checked oil still good although there were drips coming off the back of the pan

My thoughts are that with the replaced hoses - no leaks any more that pressure built somewhere and blew something out.. hoping it's a 15c ORing and not a $$k issue..

Any thoughts suggestions or places to start would be truly appreciated.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-13-2011, 05:38 AM
Powerstroke.org Rookie
 

Join Date: Sep 2010
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
No worries..

After all the panicking it was just a blown o-ring on the Strictly Diesel HPX Line. 50c fix.
Hoping it was just a bad o-ring.. on the plus side I probably have the cleanest valley in Alabama..
Reply With Quote Quick reply to this message
  #3  
Old 11-28-2011, 02:33 PM
Powerstroke.org Rookie
 

Join Date: Sep 2011
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
What part of Alabama

Sent from my Desire HD using AutoGuide App
Reply With Quote Quick reply to this message
  #4  
Old 11-29-2011, 05:24 AM
Powerstroke.org Rookie
 

Join Date: Sep 2010
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Down in Alabaster
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:50 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors