Rough idle, bad mpg - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 10-21-2011, 12:53 PM Thread Starter
Member
 
Join Date: Sep 2011
Posts: 59
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Rough idle, bad mpg

I just got new stage 2 injectors, turbo, and srp1 HPOP installed in my truck. When it first starts warm or cold it usually romps pretty hard and I have to give it gas to even out. Highway driving seems okay with a little bit of stumble around 1600rpm but runs really rough once I get off highway. Sometimes it will smooth out after a few min but sometimes it won't, sounds like its got a big cam in it or something. I think the mechanic did the ipr. I unplugged the icp idle jumped foor a second and check engine light cam on but seemed to run about the same

Ideas?
FL_Cracker is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 10-21-2011, 07:37 PM
Compression Ignition Addict
 
Join Date: Nov 2009
Location: Ringtown, PA
Posts: 618
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Most likely injector harnesses. I'd start there.


Sent from my Autoguide iPhone app

2001 F350 SRW CC 4WD LB
ZF6 w/ Southbend, 220k, DIY Intake, WW,NonEBPV Pedestal, CCV Mod, Gauges (Boost, Pyro), 2in Leveling Kit, 4" Straight MBRP, AIH Delete, 2-12" Kicker Comp's, Pioneer Amps
2001 F350 DRW EC 2WD (Rolled Over)
2000 F550 CC 2WD
Automatic, Jasper 4R100 w/Derale Pan & 6.0 Cooler, DIY Intake, AIH Delete, 4" MBRP,

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Schnot is offline  
post #3 of 5 Old 10-22-2011, 12:00 PM Thread Starter
Member
 
Join Date: Sep 2011
Posts: 59
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Replaced the harness when all the work was done. The truck just got scanned. Mechanic said the high pressure oil readings were all over the place and read really low when the truck did the romping thing. ICP? The irp is new. Ideas?
FL_Cracker is offline  
post #4 of 5 Old 10-24-2011, 02:24 PM
Member
 
Join Date: Jun 2011
Location: centural Louisiana
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
unplug the icp sensor and see it runs smooth,if so replace it,or mabey when the injectors were installed might have torn an oring
SWIFTSERVICE is offline  
post #5 of 5 Old 10-24-2011, 05:30 PM Thread Starter
Member
 
Join Date: Sep 2011
Posts: 59
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Replaced the icp today. Runs much better but not totally right. Oil on the old icp is dark and thin but i just had a oil change. Is this normal?
FL_Cracker is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome