Turbo not working. - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 10-19-2011, 07:36 PM Thread Starter
Powerstroke.org Rookie
Join Date: Oct 2011
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Turbo not working.

Hi, I'm new to the forum and just had my first problem with my PSD.

I was driving today and trying out my new tunes when I heard what sounded like one of the intercooler boots pop-off followed by loud sound of air escaping and then a flapping sound for a few seconds and now my turbo isn't making any sound like it usually does. I believe the lower boot of the intercooler hard line popped a hole in it as I have checked the clamps and boots on the upper part and they are secure, but I ran out of daylight and couldn't actually get to the lower ones. I'm thinking the the flapping sound was the pressurized air blowing the foil wrap around. Has anyone else experienced this or have any ideas what might the problem?

Thank you.
FourCorners7.3 is offline  
Sponsored Links
post #2 of 2 Old 10-20-2011, 06:49 AM
Compression Ignition Addict
Join Date: Mar 2011
Posts: 947
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 5 Times in 4 Posts
Feedback Score: 0 reviews
I've never heard of blowing a hole in the IC pipes. It's more likely one of the boots blew off after it got saturated with oil from the PCV system.
ttyR2 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome