HELP!!! low control pressure - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 10-03-2011, 07:41 PM Thread Starter Rookie
Join Date: Jun 2011
Location: downtown Houston Tx
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
truck wouldn't run when warmed up. checked fuel pressure...OK, than Looked at the ICP, oil on the plug replaced the sensor and wire, only to still have the same problem. I changed the oil and the IPR Orings... nope. I bought a new IPR... still doin it! injector Orings were next, got better throttle response, but still dying when warm. crap must be my HPOP while I'm waiting for Terminator to rebuild my pump my buddy wrecks his 7.3 powered Van, so I swap injectors with him(they had been replaced) new Orings again instal HPOP now it doesn't die when warm just has no power.
control pressure at idle is a little less than 500 and cant go over 800 duty cycle hits 60 at anything past part throttle... and pop goes the check engine light.

any thoughts on this? what can I do next? I'm almost out of ideas!

Last edited by studentdriver; 10-03-2011 at 07:51 PM. Reason: posted twice...cuz I'm a nincompoop
studentdriver is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome