2001 7.3 couple of misses and dies - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-17-2007, 12:39 PM
Powerstroke.org Rookie
 

Join Date: Aug 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2001 7.3 couple of misses and dies

I have a 2001 7.3 that has been dying while driving for a few days and seems to be getting worse. while driving, it acts like it doesn't get fuel for a second and then dies. It will start back up with no problem or delay. I have changed the throttle posistion sensor, cam posistion sensor and ICP sensor. It seems to do it more at low speeds. Any assistance would be appreciated.

kelly
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-21-2007, 12:17 PM
Compression Ignition Addict
 
Join Date: Sep 2006
Location: Woodland, MI
Posts: 300
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Is there any check engine light when it happens? Also, does the tach drop off before it dies? If so, it could be an IDM problem.

Best thing to do would be find someone with a scanner that can watch data. You could have a IPR valve taking a dump but would only be able to confirm by watching the icp pressure when the engine is acting up.
Reply With Quote Quick reply to this message
  #3  
Old 08-21-2007, 01:09 PM
Powerstroke.org Rookie
 

Join Date: Aug 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
check engine light does come on. It keeps showing the code for the ICP. As I stated , I have replaced that already. Sometimes it will do it and not bring on the check engine light. The shop is now wanting to put on a new ECM. I told them to wait on that. Is there a reliable way to test that unit before replacing it?
Reply With Quote Quick reply to this message
  #4  
Old 08-21-2007, 01:14 PM
Compression Ignition Addict
 
Join Date: Sep 2006
Location: Woodland, MI
Posts: 300
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Have them change the IPR out first. Most likely either the valve or the solenoid that controls the IPR is going bad, causing you to loose pressure in the high pressure oil circuit. It's a simple 5 minute swap, and the part is around $145. I wouldn't go to the length of swapping the ecm yet, especially since it's throwing an ICP code.
Reply With Quote Quick reply to this message
  #5  
Old 08-21-2007, 01:14 PM
Compression Ignition Addict
 
Join Date: Sep 2006
Location: Woodland, MI
Posts: 300
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Oh yeah, do you have a chip in it?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:15 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors