abnormal idle - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-14-2007, 04:20 PM
Member
 

Join Date: Apr 2007
Location: san antonio
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
abnormal idle

i have a 99 psd build date 02/98. i have had the tranny rebuild 4 times in a year and on the 2nd time it was rebuild, once i get off the high way or after i goose it a little the truck stays at 900rpm. it use to go away when i put it in neutral and now when its put in neutral it jumps to 1000-1500. i have to put it in park and then it goess away. i have no idea what it could be. i recently replaced the app sensor( accelerator pedal position sensor) and it was off by 1.5 volts at wot. every shop around here tells me it not a big deal, but it is. also i dont know if this ties in with it but i installed guages the other week to watch everything and at 10 lbs the guage flutters and the more boost the worse it gets. please help. everyone here either wants a million bucks for advise or they have no clue what they are doing. thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-20-2007, 06:06 PM
Compression Ignition Addict
 

Join Date: Jun 2007
Location: Dallas TEXAS
Posts: 200
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 3 reviews
your ICP sensor could be going out of wack, that sensor is one of the main contributors of idle quality and performance. Have it checked or unplug it and see if it is internally leaking oil, which will throw it off as well...
Reply With Quote Quick reply to this message
  #3  
Old 08-23-2007, 03:17 PM
Member
 

Join Date: Apr 2007
Location: san antonio
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
what exactly is the icp sensor and where would this be located so i can check it please?
Reply With Quote Quick reply to this message
  #4  
Old 08-23-2007, 04:12 PM
Navy Beer Guzzler

 

Join Date: Jan 2007
Location: Leander, Texas
Posts: 264
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It is located in the valley just below the valve cover on the drivers side toward the front. there is a thread here somewhere showing sensor locations.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:06 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors