Charging problems - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 07-27-2007, 10:47 AM Thread Starter
Stroken n Smoken's Avatar
Join Date: Jul 2007
Posts: 45
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Charging problems

Hey guys, new here, looks like a place to get some good info! My 99.5 PSD did something odd to me the other day, Drove to work, about 35 miles, worked my 10 hr shift and when I went to leave it cranked slow, but started, I hadnt left lights on or a door part way open. Drove home and the next morning it was dead, well crank click click, so I through the slow charger on it and let it sit all day, after work it started right up, checked the batteries and with fan on hi and lights on its showing there charging about 14.2-14.3 volts, now its been starting fine all week, any ideas? Thanks! All I have put on the truck since I bought it a year and a half ago is a Bullydog 4 bank 6 pos. chip, K&N cold air intake 4 inch MBRP exhaust Dual relief map valve and a waste gate defuser,no wierd electrical stuff.
Stroken n Smoken is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome