7.3 problems - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-12-2007, 09:54 PM
Powerstroke.org Rookie
 

Join Date: Jul 2007
Location: jackso n
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
7.3 problems

i have a 7.3 with 190,000 miles...been to heck and back but im startin to have a few problems. the overdrive light flashes on the gearshift SOMETIMES, transmission leaks only when ran on extreme/race mode for long periods of time. the light has flashed for the last 50,000 miles or so but nothing has ever happened so maybe its a sensor? the spool valves on the injectors stick also...could this be a prob down the road? any help would be appreciated! thanks!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-12-2007, 10:08 PM
Serving Our Country!
 

Join Date: Mar 2007
Location: Amboy, Illinois 61310
Posts: 236
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to SgtStroked7.3
If it has never been rebuilt and u made it to 190,000 miles, i would consider yourself lucky. The 4R100's are strong, but at 190K and then adding a chip that puts an a$$load of strain on it... ur bound to blow something. also, if you look in your owners manual, it will tell you that a flashing light be it OD or CEL means u have serious problem and it need some repair work. i would suggest taking it to a transmission place and having them put it on a diagnostic machine. if anything it will at least let u know how much longer u can drive on it without blowing it up.
Reply With Quote Quick reply to this message
  #3  
Old 07-12-2007, 10:14 PM
Compression Ignition Addict
 

Join Date: Jun 2007
Location: Harrisville Mississippi
Posts: 484
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i had a new tranny put in at 105000 the yolk broke and cracked my tranny in half and i still drove it home in 4wd
Reply With Quote Quick reply to this message
  #4  
Old 07-12-2007, 11:06 PM
Powerstroke.org Rookie
 

Join Date: Mar 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Exclamation

replace the vss on the rear diff, it should stop the flashing light,and the trans fluid coming out the seals means its to hot put a bigger cooler on. i have heard that one from a 6.0 has twice the cooling cap. you probley did the damage on the trans,if you rebulid it make sure you put in a gauge and the extra cooler
Reply With Quote Quick reply to this message
  #5  
Old 07-13-2007, 06:55 AM
Powerstroke.org Rookie
 

Join Date: Jul 2007
Location: jackso n
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by SgtStroked7.3 View Post
If it has never been rebuilt and u made it to 190,000 miles, i would consider yourself lucky. The 4R100's are strong, but at 190K and then adding a chip that puts an a$$load of strain on it... ur bound to blow something. also, if you look in your owners manual, it will tell you that a flashing light be it OD or CEL means u have serious problem and it need some repair work. i would suggest taking it to a transmission place and having them put it on a diagnostic machine. if anything it will at least let u know how much longer u can drive on it without blowing it up.
what do u mean will blow up? motor or ttranny? and no the tranny has never been rebuilt. i got the truck brand new and it has been dogged and worked like a dog eversince. she burns a little bit of oil here and there but it still pulls strong! the programmer really help the shifting quality though! thanks
Reply With Quote Quick reply to this message
  #6  
Old 07-13-2007, 07:36 AM
Compression Ignition Addict
 

Join Date: Jan 2007
Posts: 366
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Fine a good transmission shop, ask about the condition of the transmission (could trans use a shift kit?). Flush, filter, valve body ~$290~.

Between 100,000 miles and 200,000 miles, all the stuff hung off the front of the motor will need servicing, also, the injectors can be rebuilt at less cost than replacement. Water pump $200, serpentine belt $45, Alt $145, tensioner $47. Injector replacement at dealer, $4,600, by mechanic, $3,000, by you $1,700, rebuild / clean by you $400..
Reply With Quote Quick reply to this message
  #7  
Old 07-13-2007, 09:06 AM
Powerstroke.org Rookie
 

Join Date: Jul 2007
Location: jackso n
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i have already replaced waterpump/thermstat, alt., hubs, oil pump, 2 fuel pumps, ball joints, rotors and cam sensor....injectors/ tranny will go next i think...i need to get rid of it and get a new one i guess ha!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:17 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors