Problem that is driving me CRAZY! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-15-2011, 01:13 PM
Powerstroke.org Rookie
 

Join Date: Jan 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Problem that is driving me CRAZY!

Hello all,

Last March, I bought a 2001 Excursion 7.3. In July, my battery light started flashing and in August, I replaced both batteries. Since then, I have replaced the batteries four times. I have had the alternator tested at Autozone and it tested good. Today, I spent the entire day checking all wires, grounds, and plugs looking for the cause of my power drain. I even took apart the dash in hopes of maybe finding a loose wire there.

Anyway, everything seemed to check out good. I cannot seem to find the problem as to why the battery light flashes or what is draining my batteries. Even when I install the new batteries, the light immediately begins flashing. Could it be the starter? Has anyone ever had this problem and was able to find the solution? I have searched and searched online for answers...nothing I've tried has helped. Getting extremely frustrated!!!

Thanks.

Brad
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-15-2011, 01:21 PM
Banned

 

Join Date: Jul 2008
Location: Bryan/College Station/Tyler, TEXAS
Posts: 26,488
Thanks: 15
Thanked 10 Times in 9 Posts
Feedback Score: 1 reviews
Generally its the alt or wiring to the alt.


On my 97 obs, my light flckered since the single wire on the top had a bad connection from being bent for so long. But the alt was putting out a constant 14v when running so I ignored it.


But are you finding dead batts in the morn?
Reply With Quote Quick reply to this message
  #3  
Old 01-15-2011, 03:43 PM
Powerstroke.org Rookie
 

Join Date: Jan 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The first time, my batteries went almost completely dead while driving. I made it home, but as soon as I shut it off, I tried to start it up again, but didn't have enough juice. It doesn't matter what time of day it is. My batteries just keep draining. My light flashes almost all of the time and my batteries do not last very long. Just can't seem to figure it out.
Reply With Quote Quick reply to this message
  #4  
Old 01-15-2011, 04:24 PM
Banned

 

Join Date: Jul 2008
Location: Bryan/College Station/Tyler, TEXAS
Posts: 26,488
Thanks: 15
Thanked 10 Times in 9 Posts
Feedback Score: 1 reviews
check all your grounds!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:52 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors