Part #?? or where can I get? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 01-12-2011, 12:50 PM Thread Starter Fanatic
baja38ss's Avatar
Join Date: Jan 2007
Location: Pa
Posts: 144
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Part #?? or where can I get?

I have a 01 7.3 with the heat/ac stuck on defrost. My vacuum pumps running all the time which told me a had a vacuum leak. I ended up replacing the lines to the hubs. My problem is the drivers side stem on the hub the hose connects to broke off. Dealer can't find part and I also called junk yard with no luck.
If anybody can help I would appreciate it.
baja38ss is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome