Ok another truck dies post.......lol - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-08-2011, 10:08 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2007
Location: Queen Creek, AZ
Posts: 138
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok another truck dies post.......lol

Ok so my truck just died driving on the I-17 at about 65mph and I started to pull over to the right shoulder and boom it came back to life WTF. So I get about 15 miles futher down the road and it does it again, the same thing. So now I think oh **** I am about an hour & half from home now what? I get about ten more miles down the road and it dies and it wont restart for about 10 mins. then it does and I get to where I am going and a half mile away. After about two hours it starts up and then dies again a few miles down the road. I sit for about 15 mins. it starts and I am able to drive it for 20 miles to Autozone to get a new cam sensor and I put it in right there and it starts right up. Well I got to the Ford dealer and picked up a ICP sensor becuse we scanned it and it came up with that code but the ICP sensor is pricey so I didnt install it yet becuse I wanted to see if it dies again and it did. Well I got it home and it died quite a few times getting it there and I went to a repair shop and they told me that it was still my cam sensor so I bought another new factory Ford one and the FN truck still dies but now it does it within two miles and it wont start againg for hours. So I out of the blue decide to disconnect the ICP wires and its full of oil and I thought what the hell this must be it and put the new ICP in and it still does the same thing it dies and it wont start for hours. Ok so here I am now with a truck that just sits in my back yard and has for almost a month and now I am ready to try and figure this thing out. If any one has any more ideas that I can check out please let me know Thanks.

Last edited by fordmike1; 01-10-2011 at 07:04 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-11-2011, 06:42 AM
Powerstroke.org Fanatic
 

Join Date: Aug 2007
Location: Queen Creek, AZ
Posts: 138
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Does anyone have any kind of thought on this that I could check? The truck is still sitting and any help would be great. Thanks Mike.
Reply With Quote Quick reply to this message
  #3  
Old 01-11-2011, 06:58 AM
IBEW Journeyman Lineman
 

Join Date: Jun 2009
Location: Union, MO/ Pomona, CA
Posts: 772
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 2 reviews
Does it run rough at all before it stalls or after you refire it?
Reply With Quote Quick reply to this message
  #4  
Old 01-11-2011, 02:10 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2007
Location: Queen Creek, AZ
Posts: 138
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by PolarBear View Post
Does it run rough at all before it stalls or after you refire it?
Nope. It was running great that day on the freeway and then it was just like I turned the key off. When it restarts it runs like nothing ever happened and then it will just die again. It has never run rough, sputtered, hesatated or anything. It just dies and wont restart for a little while.
Reply With Quote Quick reply to this message
  #5  
Old 01-11-2011, 03:05 PM
Compression Ignition Addict
 

Join Date: Dec 2007
Posts: 4,779
Thanks: 0
Thanked 75 Times in 70 Posts
Feedback Score: 3 reviews
I know you said you changed the CPS,,,, but, those sure do sound like a bad CPS!

Could it be CPS related? Connector or wiring or something? Is it even possible you got a bad one?

PCM? IDM? NO codes at all?
Reply With Quote Quick reply to this message
  #6  
Old 01-11-2011, 04:51 PM
Member
 

Join Date: Dec 2009
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
sounds like your IDM could be going bad... also I noticed that your truck is slightly lifted, just out of curiosity, is your black plastic wheel weld cover behind the front left tire trimmed or cut at all to where water has a clear path to get up to the IDM?

Last edited by mxunit13; 01-11-2011 at 04:56 PM.
Reply With Quote Quick reply to this message
  #7  
Old 01-11-2011, 07:27 PM
Banned
 

Join Date: Oct 2009
Location: Riverside/Norco, Ca
Posts: 3,771
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
IPR or IDM for sure.
Reply With Quote Quick reply to this message
  #8  
Old 01-14-2011, 08:36 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2007
Location: Queen Creek, AZ
Posts: 138
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by NoRalPh View Post
I know you said you changed the CPS,,,, but, those sure do sound like a bad CPS!

Could it be CPS related? Connector or wiring or something? Is it even possible you got a bad one?

PCM? IDM? NO codes at all?
All the new CPS are from Ford. I put the orignal one back in and still the same problem. I checked out the wiring to the CPS and its all in great shape from what I could see.The connector is even in great shape.
Reply With Quote Quick reply to this message
  #9  
Old 01-14-2011, 08:43 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2007
Location: Queen Creek, AZ
Posts: 138
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by mxunit13 View Post
sounds like your IDM could be going bad... also I noticed that your truck is slightly lifted, just out of curiosity, is your black plastic wheel weld cover behind the front left tire trimmed or cut at all to where water has a clear path to get up to the IDM?
Yea the truck has a 4" lift and the tires dont hit at all and the wheel well is still in original shape. I havent drove the truck in any rain or water in quite some time so I dont think the IDM is bad from any water. I do how ever think that the IDM is the source of all my problems but I have not confirmed it yet. I just got a good scanner and I am going to run my truck untill it dies and then do a injector buzz test on it and see if my injectors buzz and if not then I am going to suspect the IDM is bad.
Reply With Quote Quick reply to this message
  #10  
Old 01-14-2011, 08:48 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2007
Location: Queen Creek, AZ
Posts: 138
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Dietoremain View Post
IPR or IDM for sure.
I heard that there is a nut on the IPR that can come lose and cause problems and cause the truck to die. I dont think that this is it as it runs great while it is cool or cold but dies when it warms up and then restarts after it cools down again all the time no one has touched it. I do think that the IDM is the problem here.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:53 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors