Overdrive Light Flashes - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-07-2011, 07:37 PM
Powerstroke.org Rookie
 

Join Date: Jan 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Overdrive Light Flashes

I have a '99 7.3 and when I first put the truck in drive or reverse the overdrive light will start flashing and the truck has no power and kind of chugs. Once the truck gets moving and I drive for a while the light stops flashing and it runs fine. I took it to a local dealership and they said it was my turbine shaft speed sensor. I have replaced the sensor but the ruck is doing the same thing. Any help is much appreciated.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-08-2011, 09:00 AM
Serving Our Country!
 

Join Date: Aug 2007
Location: Manor, TX
Posts: 2,788
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 2 reviews
A blinking OD light is a transmission code. Odd that the dealer didn't see a code, perhaps it is resting when when light goes off. Check your transmission fluid you may be needing a new transmission soon.
Reply With Quote Quick reply to this message
  #3  
Old 01-08-2011, 11:06 AM
Compression Ignition Addict
 

Join Date: Mar 2010
Location: mokena IL
Posts: 315
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
take it to a good trans shop before you do more damage
Reply With Quote Quick reply to this message
  #4  
Old 01-08-2011, 11:25 AM
Powerstroke.org Sponsor


 

Join Date: Nov 2008
Location: *near* Portland, OR
Posts: 8,768
Thanks: 0
Thanked 6 Times in 4 Posts
Feedback Score: 2 reviews
Send a message via AIM to Derek@VisionDiesel Send a message via Yahoo to Derek@VisionDiesel
good bye transmission
Reply With Quote Quick reply to this message
  #5  
Old 01-08-2011, 02:21 PM
Powerstroke Techie

 

Join Date: Oct 2007
Location: Saint Cloud, WI
Posts: 4,455
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
First off which sensor did you replace? There are 2 of them on top of the trans that are the same. The front one is the tss (turbine speed sensor) and the back one is the oss (output speed sensor). Otherwise I have seen one of those connectors cause an intermittent connection issue that did the same thing.
Reply With Quote Quick reply to this message
  #6  
Old 01-09-2011, 09:41 AM
Powerstroke.org Rookie
 

Join Date: Jan 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I replaced the back one. I didn't know there were two. The dealership told me where it was and I didn't bother looking for the other one. I will get another sensor and replace the tss and see what happens. I really hope its not the transmission going out.
Reply With Quote Quick reply to this message
  #7  
Old 01-09-2011, 10:39 AM
Powerstroke Techie

 

Join Date: Oct 2007
Location: Saint Cloud, WI
Posts: 4,455
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
If you have the one that you took out you can install that one in the front position.
Reply With Quote Quick reply to this message
  #8  
Old 01-11-2011, 12:22 PM
Member
 

Join Date: Apr 2010
Posts: 59
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
every time mine has flashed like that i ended up having to replace the speed sensor on the rear diff.... but i didnt have any power loss just a flashing light
Reply With Quote Quick reply to this message
  #9  
Old 01-11-2011, 12:46 PM
Powerstroke.org Sponsor


 

Join Date: Nov 2008
Location: *near* Portland, OR
Posts: 8,768
Thanks: 0
Thanked 6 Times in 4 Posts
Feedback Score: 2 reviews
Send a message via AIM to Derek@VisionDiesel Send a message via Yahoo to Derek@VisionDiesel
I have a transmission for you...fully functional $1350 shipped
Reply With Quote Quick reply to this message
  #10  
Old 01-11-2011, 01:19 PM
Member
 

Join Date: Apr 2010
Posts: 59
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
thats a pretty good price dude... ive been looking around (just did mine) and 1500 is about the norm for cheap rebuild... and well those that are cheaper have issues for example i have just over 1000 in mine and dude is about to pull it for the 3rd time..
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:33 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors