Electrical system problems: window door locks - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 12-30-2010, 05:20 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Dec 2010
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Electrical system problems: window door locks

I have a 99 f250 4 door and my driver window won't roll down. I replaced the motor and all it does is make a "click" noise at the fuse box. The relay seems to be good. Also the power door locks won't go all the way up or down when you hit the button. They try to move but won't go all the way on all 4 doors. Any suggestions?? Thanks
Ryanwc1996 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 12-30-2010, 06:14 AM
ARMY MOM!!!!
 
korg70kbc's Avatar
 
Join Date: Nov 2008
Location: Colfax, Ca Sierra Nevadas
Posts: 3,053
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to korg70kbc
Quote:
Originally Posted by Ryanwc1996 View Post
I have a 99 f250 4 door and my driver window won't roll down. I replaced the motor and all it does is make a "click" noise at the fuse box. The relay seems to be good. Also the power door locks won't go all the way up or down when you hit the button. They try to move but won't go all the way on all 4 doors. Any suggestions?? Thanks
I had the same problem & it was numerous things.
1 the switch
2. the relay was bad
3. the fuse panel was toast for whatever reason
4. the actuator was bad

there are fixes for the actuator u can try 1st I will see if I can find the link.
switches have been pretty cheap on ebay.
I have a spare working fuse panel


btw

Hope u can find the problem, at least its winter, mine went south in the summer & it was hot..........


here u go, i used this link..... http://www.ford-trucks.com/forums/44...-fixed-26.html

Laurie



SOLD NCHornet's CCV MOD!, stancor GP relay, zoodad, 6637, fumoto valve, 4" turbo back no cat/muffler, Autometer gauges, & AE avail.

Last edited by korg70kbc; 12-30-2010 at 06:18 AM. Reason: adding link
korg70kbc is offline  
Sponsored Links
Advertisement
 
Reply

Tags
bad ecm

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome