Little Problem - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 06-30-2007, 04:49 PM Thread Starter
Thats Mr. Oil Leak.....

 
MrJohnWayne's Avatar
 
Join Date: Oct 2006
Location: Waller/Magnolia
Posts: 9,604
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 9
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Little Problem

As most of you know I recently purchased the Stealh DHPOP kit. Got it installed today after a few hours. Really wasnt as bad as I though until I tried to put both pumps back in. That is pretty tricky and if you don't stick your tounge out right it could take days So I got it installed and did all my final checks, oil, wires etc... Start it up. Took about 4 seconds and fired right up. Had a mean lope too till i goosed the go pedal then it evened out and idled like normal. let it idle to check for leaks and what not. Drove it around the block at work a couple times goosing it now and then. small drip here and there which I didnt pay any attention too cause the valley still had some oil in it from the install. Start to drive home. Get on a backroad and open it up and boy howdy is there a difference in the top end now!! But I blew my CAC tube!! Again!! pulled over and popped the hood. Holy :censord: cow. Oil everywhere!!! I think I now what the problem is. Atleast I hope I think I know what it is. but I was kinda po'd and needed to vent. Sorry....

John Wayne
Owner and Operator of the
REDNECK VALDEZ
You can find me on FaceBook
MrJohnWayne is offline  
post #2 of 8 Old 06-30-2007, 04:58 PM
Compression Ignition Addict
 
slammedSI's Avatar
 
Join Date: Aug 2006
Location: Vernon, Texas
Posts: 3,333
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to slammedSI Send a message via MSN to slammedSI Send a message via Yahoo to slammedSI
Hope you get it fixed! time to change your sig.

-Bobby Crews- AKA Dr. Cookie Cutter!

2012 Ford F150 Ecoboost
-STOCK-

Quote:
Originally Posted by Dirk View Post
A 7.3 with an edge should never get into a race. Unless it's with a kid on a bicycle.. and the bike has a flat.
slammedSI is offline  
post #3 of 8 Old 06-30-2007, 05:56 PM
Rob
Super Moderator



 
Rob's Avatar
 
Join Date: Aug 2006
Location: Layton, Utah
Posts: 13,244
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 3
Thanked 7 Times in 4 Posts
Feedback Score: 0 reviews
Send a message via AIM to Rob Send a message via MSN to Rob Send a message via Skype™ to Rob
good luck on getting it fixed.

Rob, The Investigator!
Audentes Fortuna Juvat
(Fortune Favors The Bold)
Rwalker@Powerstroke.Org
The Org. Staff reserves the right to
move, modify, delete or merge threads/posts
at our discretion, without explanation
at any time.

Rob is offline  
post #4 of 8 Old 06-30-2007, 06:05 PM
DKR
<--Pro Cooler Racer
 
DKR's Avatar
 
Join Date: Dec 2006
Location: Newark, Delaware
Posts: 8,216
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Skype™ to DKR
No problem with the venting John...we're here to help or just lend an ear....ya'all heard me vent pretty darn good back in March with my Quad Commander issues...hope you get it all worked out.

Eric
2007 F250 6.0l King Ranch CC LB
Sponsored by Innovative Diesel Performance
SCT XCal2 w/ Custom Files & FICM tuning
DashDAQ Series II; ARP Headstuds; AFE Stage 2 XP Intake w/ Proguard 7
Industrial Injection 190cc injectors; FASS 150/180; ITP Regulated Return
'03 Turbo Swap; Zex N2O Dry Shot; CFM Smallmouth Intake Elbow
Zoodad w/ Predator Screen; MBRP 4" Cool Duals Straight Piped
EGR Delete w/ full manifold; Coolant Bypass Filter; Train Horns
Eclipse AVN62D; High Idle Mod; BFG ATs 285-65/20s

Truck- 12.51sec @ 108mph @ ~7700lbs (1/4 mi)
Cooler- 39.93sec @ 12.12mph @ ~180lbs (1/8 mi)

Email: DKR@powerstroke.org
DKR is offline  
post #5 of 8 Old 07-01-2007, 10:19 AM Thread Starter
Thats Mr. Oil Leak.....

 
MrJohnWayne's Avatar
 
Join Date: Oct 2006
Location: Waller/Magnolia
Posts: 9,604
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 9
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Well I found the leak. Turns out to be the front HPOP seal. Now if I could just get someone else to change it...... oh well looks like I'll be able to do it blindfolded after this is done.......

John Wayne
Owner and Operator of the
REDNECK VALDEZ
You can find me on FaceBook
MrJohnWayne is offline  
post #6 of 8 Old 07-01-2007, 10:22 AM
Compression Ignition Addict
 
cj41foley's Avatar
 
Join Date: Dec 2006
Location: Tuscaloosa Alabama
Posts: 1,770
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Git-er-done

Jason
2006 F250 2wd 6.0 psd, 8.96 1/8th mile with canned SCT tunes, now running Spartan Hybrid Race tune! AFE Stage 2 PRO DRY S, 4" turbo back str8 pipe in front of rear tire, auto, crew cab short bed, ZOO DAD mod, 5% tint over the factory tint.
Track Times!
Reaction---.674
60 ft-------1.892
594 ft------8.370
1/8th ET---8.965
1/8th MPH--75.63
cj41foley is offline  
post #7 of 8 Old 07-01-2007, 10:23 AM
Banned
 
Join Date: Apr 2007
Location: Ponca City, Okla
Posts: 1,089
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via MSN to Blue01F250 Send a message via Yahoo to Blue01F250
man i hate doing things twice! lol good luck!
Blue01F250 is offline  
post #8 of 8 Old 07-01-2007, 10:26 AM Thread Starter
Thats Mr. Oil Leak.....

 
MrJohnWayne's Avatar
 
Join Date: Oct 2006
Location: Waller/Magnolia
Posts: 9,604
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 9
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
me to brother... me too. And I don't know why it didnt seal. I took extra time being careful not to damage it. And it held for a while. don't know what made it start leaking??

John Wayne
Owner and Operator of the
REDNECK VALDEZ
You can find me on FaceBook
MrJohnWayne is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome