speedo quit working abs light came on?? - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 11-30-2010, 06:09 PM Thread Starter
Member
 
NIX 4X4's Avatar
 
Join Date: Dec 2007
Location: East Tennessee
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to NIX 4X4
speedo quit working abs light came on??

Tonight I was just driving and my speedometer quit working. I parked and when i got back in and started my truck up it still did not work and the abs light was on. The speedometer bounced a couple times on the way home but nothing. Any help would be appreciated I have read a few things but just don't know for sure. My truck is a 2000 "manual" if that makes a differance.

Any help????





NIX 4x4
NIX 4X4 is offline  
post #2 of 5 Old 11-30-2010, 08:09 PM
Compression Ignition Addict
 
Join Date: Jan 2008
Posts: 1,286
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
The rear speed sensor has probably failed. In the center of the rear axle toward the top.

04 F-550 CC 6.0 4x4 cab n chassis 4.88 XLT 193K
Money maker with utility bed.
97 F-350 CC 7.3 ZF-5 4x4 4.10 324K
Moves my stuff around.
Hardline is offline  
post #3 of 5 Old 01-25-2011, 06:24 PM
Powerstroke.org Rookie
 
Join Date: Jan 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
My truck done the same thing. I have changed the rear speed sensor and it still is not working
jamie32 is offline  
post #4 of 5 Old 01-25-2011, 06:43 PM
Powerstroke.org Fanatic
 
Dixienormous's Avatar
 
Join Date: Nov 2010
Location: DeLand,FL
Posts: 144
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
i think i measures speed from three points the two front hubs and the rear axle check to see if all the wires are in place

2005 F-250 FX4

2001 F-550 4x4 Western hauler

2004 F-250 cummins 2.5ton Rockwells on 53s

1965 Mustang GT 4 speed to loader

1969 pink mustang convertible GT M-code 4 speed toploaer

06 dodge ram 2500 TRX-4 straight piped and intake

IN GOD WE TRUST
Dixienormous is offline  
post #5 of 5 Old 01-31-2011, 12:35 PM
Powerstroke.org Rookie
 
Join Date: Aug 2010
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Fort what its worth, this happend to me on a couple of occasions, it was Alternator related.
crooks is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome