2001 F350 Starting Problem. - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 10-18-2010, 08:46 PM Thread Starter
Powerstroke.org Rookie
Join Date: Oct 2010
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2001 F350 Starting Problem.

First off the truck has a Banks chip in it along with turbo intercooler and exhaust along with a 6 speed tranny. The ebrake is streched out and hardly works if that matters. Last year the high idle went out for the cold start ups. This year its having a problem starting. Changed Glow plugs and relay, helped for a while but no longer works. If it does manage to start it huffs white smoke. Whats the first thing to start checking on to make it all work.

I restore old Air Cooled VWs so this is a major undertaking for me.
oddball383 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome