broke my 4x4 - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 10-11-2010, 07:13 AM Thread Starter
Compression Ignition Addict
 
lhsnbsaoa's Avatar
 
Join Date: Oct 2009
Posts: 790
Thanks: 2
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Unhappy broke my 4x4

last week, i went out mudding with some friends and didnt have any problem, used my 4x4 (used it pretty hard in reverse too). the next day while in 2wd pulling out of work, i heard what sounded like a gear grinding and it felt like my tranny downshifted and slowed my truck. i restarted it and never had that problem again, but now my 4x4 wont turn on. any ideas?
lhsnbsaoa is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome