SES light is on, goes off and runs rough... - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 09-15-2010, 09:13 AM Thread Starter Rookie
Join Date: Jul 2007
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
SES light is on, goes off and runs rough...

working on a 2000 e-350 7.3, it now suffers from a loss of power with white smoke, dies going up hills less than a mile from the house. had a really poor connection at pos battery terminal but got that issue sorted out with new terminals and db starter, etc. moving on and trying to shed some light on my other issues...

about a year ago when it would drive, the SES light was on all the time after a service. pretty frequently, while driving, the SES light would go off and the truck would start to run rough and shake a bit. if you left your foot off of the accel pedal, the light would eventually come back on and the truck would run fine again...

anything obvious about that? seems like it should be the other way around...

don't have an AE scanner. going to go unplug the ICP and see what's up. the alternator seemed to not be putting out anything for a minute, and then jumped up to 13-14v. had a bit of AC voltage across also, bad diode in alternator? could that be causing this problem or just another issue

sorry for the rambling, thanks in advance!

trevvahhh is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome