7.3 engine problems - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 09-04-2010, 02:17 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2010
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
7.3 engine problems

I bought the truck about a month ago and it died a few times but did not throw a code; after reading some forums I replaced the cam sensor and it seemed to fix the problem for a bit, but today it started to die again and very frequently. I can not go more than a few miles without the engine dying. A check engine light comes on sometimes, but it goes away if I turn the ignition all the way off. I pulled codes and here is what came up.

P0344 Cam pos sensor intermittent--I was thinking this may be a left over code from the cam sensor replacement, but I did pull the battery after it was completed.

p0478 Exh pressure cont valve high

p470 exh press sensor fault

P1211 ICP press above/below desired

The truck is mostly stock with the exception of exhaust (single stack). I was told it also has 80hp injectors added, but it does not blow any black smoke. I was also told there is no tune. The truck has 350k mi but I was told the engine and tranny are fairly new 60k on motor, 25k on trans.

I am new to diesel maintenance, so any help would be greatly appreciated.

Is there any one problem that would contribute to all these codes?

Thanks for your help.
LeadF00T is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 09-04-2010, 02:46 AM
Compression Ignition Addict
 
Join Date: Sep 2007
Location: Victorville Ca
Posts: 317
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Add some more information to it. When does it die? While driving, at a stop, when doing something like stepping on the brakes, turning or ????? Is the engine cold, fulling warmed up, no rhyme or reason. Anything else you can think of. Good luck. I have a full set of shop manuals for the 02 to reference for you

02 F350 CC 7.3 PS, auto, 6x6, 4.10 gears LB. AFE stage 2 intake, 4" AFE SS exh, 6.0 atf cooler, DP tuner with five stages Eng Temp gauge, EGT guage and Trans temp gauge. J.Woods valve body ATS turbo housing. Cooling sys filter & waterless coolant. NON WORKING POS FASS fuel filter sys. Brightbox headlites. I don't care what they say "There's no replacement for displacement." Don't believe statements about anything being better than a 7.3
GOD BLESS AMERICA!!!!
Bart_3500 is offline  
post #3 of 7 Old 09-04-2010, 03:03 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2010
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
dies at all settings

If I am driving at highway speeds, it dies drops about 1k rpm but will stay running, but the engine loses all power for less than a second. If I am stopped or at low speed it will shut off completely.

It was raining today and it was the first time the dying has happened since the last rain. May be just a coincidence though. Right before I replaced the cam pos sensor it was raining too, but I am not sure of the weather the first few times the problem occurred.

I also cannot verify either the rebuild or injectors, just taking the word of the seller.

Last edited by LeadF00T; 09-04-2010 at 03:07 AM.
LeadF00T is offline  
post #4 of 7 Old 09-04-2010, 05:13 AM
Shaking the Bush Boss
 
CHUCK's Avatar
 
Join Date: Feb 2007
Location: Salisbury, NC
Posts: 9,740
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
bump up for ya............

Chuck
CHUCK is offline  
post #5 of 7 Old 09-05-2010, 08:23 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2010
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No rain no problem

I have driven the truck for 2 days again and when it was dry out, there were no problems. Hoping someone else has experienced something similar.
LeadF00T is offline  
post #6 of 7 Old 09-06-2010, 07:52 AM
Compression Ignition Addict
 
Join Date: Sep 2007
Location: Victorville Ca
Posts: 317
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
This may sound like a stupid question, but since you've owned the truck for only a couple months. Have you drained the fuel filter of any water in the trap? You may also want to change the filter. If you need help with either of these maintenance items let us know and we'll be glad to tell you how to do it. Diesels don't like water. If you have a load of water in your filter system rain could put just enough moisture in the air to send it over the edge. That may be your problem either way best to change out the filters sense you don't know when the filters were changed.

02 F350 CC 7.3 PS, auto, 6x6, 4.10 gears LB. AFE stage 2 intake, 4" AFE SS exh, 6.0 atf cooler, DP tuner with five stages Eng Temp gauge, EGT guage and Trans temp gauge. J.Woods valve body ATS turbo housing. Cooling sys filter & waterless coolant. NON WORKING POS FASS fuel filter sys. Brightbox headlites. I don't care what they say "There's no replacement for displacement." Don't believe statements about anything being better than a 7.3
GOD BLESS AMERICA!!!!
Bart_3500 is offline  
post #7 of 7 Old 09-06-2010, 07:54 AM
Compression Ignition Addict
 
sldghamr's Avatar
 
Join Date: Jan 2007
Location: Santa Rosa, CA
Posts: 2,026
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
those codes you mentioned, i pretty sure that means your IDM is dying. i had similar codes a couple years back, ended up being the IDM.

if you see a light at the end of the tunnel, it's probably just a photon torpedo
sldghamr is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome