Cruise Control Won't Work...? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-13-2010, 02:19 PM
Compression Ignition Addict
 

Join Date: Jun 2010
Posts: 197
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Cruise Control Won't Work...?

Cruise control stopped working in my truck about a week ago. Finally today I looked for the fuse and can't locate it in the manual....? I started pulled all of the mini 10 amp and 15 amp fuses to check them 1 by 1 and they all looked fine. Does anyone have any suggestions?? Thanks in advance!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-13-2010, 02:21 PM
Compression Ignition Addict
 

Join Date: Apr 2007
Posts: 3,366
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
check your neutral safety switch to make sure everything is ok
Reply With Quote Quick reply to this message
  #3  
Old 08-13-2010, 03:05 PM
Compression Ignition Addict
 

Join Date: Jun 2010
Posts: 197
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
How do you check that? If I unhooked the battery's and left them for half hour and hooked them back up would that reset it? Thanks
Reply With Quote Quick reply to this message
  #4  
Old 08-24-2010, 02:37 PM
Powerstroke.org Rookie
 

Join Date: Aug 2010
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I just bought a 2000 f250 and the cruise didn't work so I replaced the clockspring. It works great now.
Reply With Quote Quick reply to this message
  #5  
Old 08-24-2010, 05:51 PM
Compression Ignition Addict
 

Join Date: Jun 2010
Posts: 197
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Can anyone give a more detailed description on how to check the neutral safety switch and the clockspring?
Reply With Quote Quick reply to this message
  #6  
Old 10-05-2010, 10:00 AM
Compression Ignition Addict
 

Join Date: Jun 2010
Posts: 197
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Still no cruise control.. even when I push the cruise control button and hit "set" none of the cruise control dash lights come on so would that indicate bad clockspring?
Reply With Quote Quick reply to this message
  #7  
Old 10-06-2010, 01:00 AM
Compression Ignition Addict
 

Join Date: Jun 2010
Location: Tucson
Posts: 172
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
im wondering this too.
i myself have a 6 spd manual, and the NSS was bypassed for the remote start.
Reply With Quote Quick reply to this message
  #8  
Old 10-11-2010, 05:52 AM
Member
 

Join Date: Aug 2010
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I had the same issue and it was the emergency brake switch, may not be your issue but worth a look. For some reason it wasn't messed up enough to engage the light in the cluster but wouldn't let the cruise control turn on. If you look just above the e-brake you will see a little switch, if for some reason it isn't fully closed cruise will not work.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:06 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors