HELP: Runing rough after WOT & Differential issues - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-16-2009, 09:35 AM
Member
 

Join Date: Jun 2009
Posts: 52
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Unhappy HELP: Runing rough after WOT & Differential issues

Well guys I have this issue that it's been bugging me, and it looks like it's getting worse by the week.

The Truck:

2001
F-250 extended cab
7.3L Turbo Diesel
6spd Manual
2WD
169,000 Miles

The Issue:

After I do a WOT pull, and I come to a stop (traffic light) the engine is running pretty rough; the whole cab shakes fast for a minute or two, and eventually it settles down going back to normal (running very smooth).

I tried to replicate the issue but it only happens after I go WOT, not even during the pull, during the pull the truck pulls hard too.


What I've done:
Change the fuel filter.
Change the oil.
Do a visual inspection of the charge pipes, everything looks in place.
Change the air filter.
Change the O-rings that leak in the fuel bowl.


Differential Issue:

I have an open diff, or none locking diff in the rear, and every time that it rains and I'm starting to roll the passenger side tire spins.

It's even worse when I'm taking a right turn, the wheel just spins and I have to play with the gas pedal to get traction again.

Is this normal in these trucks?

How hard it is to do a convert ion to a LSD (Limited Slip Differential), or a locking differential?


Extra Info:

Tires are in good condition
I have not change the fluid yet.


I appreciate all the help/tips with these issues guys.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-22-2009, 07:44 PM
Member
 

Join Date: Jun 2009
Posts: 52
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Found that the issue of rough idle after a WOT pull was oil contamination thru the crankcase ventilation system, once I build me an intake the issue was gone and now it purrs likea kitten after a WOT pull.

My DIY Intake Rev. A (turbo thru filter)
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:40 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors