EBPV Problem - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 12-11-2009, 01:16 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jun 2009
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
EBPV Problem

Hello this is my first post but I've been frequenting the forums for months. I usually find everything i need when i search. My truck recently has been having problems with the EBPV, it keeps engaging no matter how warm the truck is. Anyways I unplugged (or at least I think I did) the wire for the EBPV. When I took it out for a test ride it did the same thing again with the plug out. Im pretty sure I got the right plug or maybe theres another or I got the wrong one. For some reason I can't post a pic of what I pulled but if you message me ill send it to you. Any help would be greatly appreciated.


My trucks an 01 F-350.
Green_Giant is offline  
post #2 of 4 Old 12-11-2009, 01:27 PM
PMR = JUNK

 
Jake's Avatar
 
Join Date: Nov 2007
Location: NW, Ohio
Posts: 11,199
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
Send a message via AIM to Jake Send a message via Yahoo to Jake
Probably the wrong plug. The plug you want is kinda hard to get to. Its on the turbo pedestal. Down in the valley of the engine.

BPS President

2000 F-250, forged rods, 38r turbo, BTS trans, TW tuning and Bad Night Special 50 horse Caterpillar injectors

2002 F-350, remote engine mod



Quote:
Originally Posted by alberta 7.3 View Post
Yeah, I'd probably feel a bit drained after firing twice in rapid succession.
Facebook: Jake Phillips. If you add me tell me who you are.

Jake is offline  
post #3 of 4 Old 12-11-2009, 01:42 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jun 2009
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I was just told it has a wire clip, Do I need to remove anything to get to it?
Green_Giant is offline  
post #4 of 4 Old 12-11-2009, 01:46 PM
PMR = JUNK

 
Jake's Avatar
 
Join Date: Nov 2007
Location: NW, Ohio
Posts: 11,199
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
Send a message via AIM to Jake Send a message via Yahoo to Jake
Yeah, its got a wire clip. You just have to snake your hand down there to get to it.

BPS President

2000 F-250, forged rods, 38r turbo, BTS trans, TW tuning and Bad Night Special 50 horse Caterpillar injectors

2002 F-350, remote engine mod



Quote:
Originally Posted by alberta 7.3 View Post
Yeah, I'd probably feel a bit drained after firing twice in rapid succession.
Facebook: Jake Phillips. If you add me tell me who you are.

Jake is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome