Help!! DTC P0603 - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-05-2009, 02:04 PM
Compression Ignition Addict
 

Join Date: Aug 2006
Location: Deerfield Beach
Posts: 200
Thanks: 4
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
Help!! DTC P0603

Truck won't run and this is the DTC P0603. I looked it up but don't understand what it is or how to fix.....just a sensor I hope. Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-05-2009, 02:28 PM
Compression Ignition Addict
 

Join Date: Dec 2007
Posts: 4,760
Thanks: 0
Thanked 73 Times in 68 Posts
Feedback Score: 3 reviews
Nothing to worry about, P0603 says your batteries have been disconnected recently.

Not Starting isn't part of it UNLESS it won't even "crank" then it's telling you your PCMs, "keep alive" memory has been erased because of a Total Loss of power to it.
Reply With Quote Quick reply to this message
  #3  
Old 12-05-2009, 07:50 PM
Compression Ignition Addict
 

Join Date: Aug 2006
Location: Deerfield Beach
Posts: 200
Thanks: 4
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
I changed batteries a few months ago so maybe its from then. What its doing now is when I start it it , let me see if I can explain, it runs like I'm taking my foot and mashing the gas and then lift, then mash, then lift and so on, but not reving it up, just mashing and lifting quickly, almost like i'm holding the pedal down and turning the ignition on and off real fast. If I touch the pedal while its doing this it smooths out and idles normal. I don't know if that makes any sense....I'm going to make a video in the morning so I can show what its doing.
Reply With Quote Quick reply to this message
  #4  
Old 12-06-2009, 05:47 AM
Powerstroke Junkie


 

Join Date: Aug 2006
Location: Mayberry, NC
Posts: 8,309
Thanks: 0
Thanked 32 Times in 9 Posts
Feedback Score: 0 reviews
I already replied to the same question you posted in the 7.3 section. I would check your GP system, that is where your problem is, time to do some work. Takes 30 min to do the entire system.

NCH
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:44 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors