Help!! DTC P0603 - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 12-05-2009, 02:04 PM Thread Starter
Compression Ignition Addict
 
027.3's Avatar
 
Join Date: Aug 2006
Location: Deerfield Beach
Posts: 219
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 5
Thanked 1 Time in 1 Post
Feedback Score: 2 reviews
Help!! DTC P0603

Truck won't run and this is the DTC P0603. I looked it up but don't understand what it is or how to fix.....just a sensor I hope. Thanks

'02 7.3 4 door 4X4 -- Leveled, WIcked wheel,4" turbo back w/ 5" tip, 6637, foil delete, zoodad mod, hutch/Harpoon mod, glow shift Egt & boost, 4- 7" 55w HIDs
027.3 is offline  
post #2 of 4 Old 12-05-2009, 02:28 PM
Compression Ignition Addict
 
Join Date: Dec 2007
Posts: 6,125
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 62 Post(s)
Thanks: 7
Thanked 219 Times in 210 Posts
Feedback Score: 3 reviews
Nothing to worry about, P0603 says your batteries have been disconnected recently.

Not Starting isn't part of it UNLESS it won't even "crank" then it's telling you your PCMs, "keep alive" memory has been erased because of a Total Loss of power to it.
NoRalPh is offline  
post #3 of 4 Old 12-05-2009, 07:50 PM Thread Starter
Compression Ignition Addict
 
027.3's Avatar
 
Join Date: Aug 2006
Location: Deerfield Beach
Posts: 219
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 5
Thanked 1 Time in 1 Post
Feedback Score: 2 reviews
I changed batteries a few months ago so maybe its from then. What its doing now is when I start it it , let me see if I can explain, it runs like I'm taking my foot and mashing the gas and then lift, then mash, then lift and so on, but not reving it up, just mashing and lifting quickly, almost like i'm holding the pedal down and turning the ignition on and off real fast. If I touch the pedal while its doing this it smooths out and idles normal. I don't know if that makes any sense....I'm going to make a video in the morning so I can show what its doing.

'02 7.3 4 door 4X4 -- Leveled, WIcked wheel,4" turbo back w/ 5" tip, 6637, foil delete, zoodad mod, hutch/Harpoon mod, glow shift Egt & boost, 4- 7" 55w HIDs
027.3 is offline  
post #4 of 4 Old 12-06-2009, 05:47 AM
Powerstroke Junkie


 
NCHornet's Avatar
 
Join Date: Aug 2006
Location: Mayberry, NC
Posts: 8,308
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 51 Times in 11 Posts
Feedback Score: 0 reviews
I already replied to the same question you posted in the 7.3 section. I would check your GP system, that is where your problem is, time to do some work. Takes 30 min to do the entire system.

NCH

NCH
Proud Father of USAF Airman


2000 F350 DRW,CC,LB, 4X4, Western Hauler Pkg.
Ford AIS/ BTM, FTVB
My CCV MOD, Coolant filter
06 Grill, 05 lights,6.0 trans cooler
Cyro/Hawks, JVC Touchscreen HU, JL C5's, Infinity 800watt amp,
DP tunes, 60 tow/80 e/120 race, on a SCT2 tuner
P3 controller, Brite Box Turbo Lifesaver
KMC Wheels x 4

http://s132.photobucket.com/user/NCH...=recent&page=1

Friends Don't Let Friends Drive Trucks With Generic Tunes
NCHornet is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome