Battery light blinking - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 12-05-2009, 12:31 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Dec 2006
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Battery light blinking

Battery light in the dash blinks on and off randomly and sometimes the healights dim. Guessing bad ground, but dunno.
classicpw is offline  
post #2 of 9 Old 12-05-2009, 01:31 PM
Compression Ignition Addict
 
jesilvas's Avatar
 
Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,148
Thanks: 0
Thanked 27 Times in 25 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
No probably something is wrong. Not sure if that means there is a soft code or not. What does your volt gauge look like while running?
How does the truck start?



2000 F-350 Lariat Super Duty, Dually, CCLB, 7.3L
4R100, 2wd
330,000 + miles
jesilvas is offline  
post #3 of 9 Old 12-05-2009, 01:36 PM
Compression Ignition Addict
 
Join Date: May 2008
Location: Seven Valleys, Pa
Posts: 164
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
had this happen to me. Check all the fuses under the dash and under the hood and make sure they are all tight. On fords tech site I found that when mine would come on intermittently. The fuse gets loose and loses connection.

FOR SALE
2000 F-350XLT 6sp ext cab dually
K&N cold air intake
overboost annihilater
GDS fuel spring
Valair clutch
TS chip
4" down 5" back 6" tip
isspro gauges
unplugged wastegate
GTP38R
00forddiesel is offline  
post #4 of 9 Old 12-06-2009, 05:08 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Dec 2006
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
truck starts fine, but volt guage is low at start, then jumps up at accelleration to normal
classicpw is offline  
post #5 of 9 Old 12-06-2009, 05:46 AM
Powerstroke Junkie


 
NCHornet's Avatar
 
Join Date: Aug 2006
Location: Mayberry, NC
Posts: 8,308
Thanks: 0
Thanked 51 Times in 11 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I would have the batteries and alt both tested and obviously inspect your grounds.

NCH

NCH
Proud Father of USAF Airman


2000 F350 DRW,CC,LB, 4X4, Western Hauler Pkg.
Ford AIS/ BTM, FTVB
My CCV MOD, Coolant filter
06 Grill, 05 lights,6.0 trans cooler
Cyro/Hawks, JVC Touchscreen HU, JL C5's, Infinity 800watt amp,
DP tunes, 60 tow/80 e/120 race, on a SCT2 tuner
P3 controller, Brite Box Turbo Lifesaver
KMC Wheels x 4

http://s132.photobucket.com/user/NCH...=recent&page=1

Friends Don't Let Friends Drive Trucks With Generic Tunes
NCHornet is offline  
post #6 of 9 Old 12-06-2009, 05:50 AM
Let's go B's!!!!

 
Southpaw's Avatar
 
Join Date: Mar 2007
Location: Remington, Va. U.S.A.
Posts: 6,017
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 5 reviews
I had the exact same issue last year---->Alternator

Chris

2002 Crew Cab Long Bed
4" BDS, 35x13.50 Cooper STT on 20x10 Black Rockstars, and other stuff.....310,000 miles and counting...
<><
2 Thessalonians 3 v.6-15

Southpaw is offline  
post #7 of 9 Old 12-07-2009, 01:31 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Dec 2006
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
new alternator
classicpw is offline  
post #8 of 9 Old 12-07-2009, 06:19 PM
Powerstroke.org Fanatic
 
Join Date: Nov 2006
Posts: 116
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Alternator fixed it when mine came on. You can get yourself a plug in the cig lighter socket 12 volt gauge to check the voltage as you're driving to see if the alternator is putting out like it should...the factory gauge just lets you know if its charging but not really accurate for how much exactly. More of an idiot light type gauge.
losfinch is offline  
post #9 of 9 Old 12-08-2009, 12:18 AM
Mob boss

 
Jarrod B's Avatar
 
Join Date: Jul 2008
Location: Austin Texas
Posts: 26,950
Thanks: 25
Thanked 27 Times in 25 Posts
Mentioned: 2 Post(s)
Quoted: 148 Post(s)
Feedback Score: 1 reviews
sounds like the alt is going out or theres a loose connection somewhere. for my case, the alt needed rebuilt and the single wire ontop of the alt was broke so it flashed at low idle most of the time and flashed when ever it wanted to.

2006 Ford F250 CCSB FX4 6.0

Sold
1997 F350 CCLB 2WD 7.3
1999 F350 CCLB 4WD 7.3
2003 F350 CCLB FX4 6.0





LSP Chapter Director

LSP Group Threads
http://www.powerstroke.org/forum/lon...-powerstrokes/
Jarrod B is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome