Low boost and chugging problem. Please, anybody, help! - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 03-13-2007, 05:04 PM Thread Starter
Powerstroke.org Rookie
 
fireballe21's Avatar
 
Join Date: Mar 2007
Location: Savannah, GA
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via Yahoo to fireballe21
Low boost and chugging problem. Please, anybody, help!

Hey guys, Im new here and searching for some advice. My boost seems to be very low since I installed the rebuilt turbo. Cant get any boost until almost 1800 rpm and boost wont go over 12psi at wide open throttle. Any ideas??? Also when the trans shifts up from any gear, it chugs or whatever it maybe called. Did this before and after the tranny build up. Does this at any speed and throttle postion. Only when it shifts. Please help. Thanks in advance.

early '99 (10/98) F350 SRW 4x4, CC, long bed, 7.3L, AFE stage II, Banks Six-Gun, MBRP 4", Zoo-Dad mod, DieselSite HX mod, Nitto Terra Graps 305/70/16, Custom built stock trans with roller bearings and billet T/C.
fireballe21 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 03-15-2007, 04:32 PM
Compression Ignition Addict
 
Join Date: Dec 2006
Posts: 1,256
Thanks: 0
Thanked 7 Times in 7 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
This is hard to explain, but I'll try.
The e4od/4r100 has a unique charactristic of applying the tc under heavy throttle. It can actually apply in first gear if the pedal is pressed allmost to the floor. This can sometimes cause the shifts to be abrubt.
If you have an engine with a lack of power, then you must press the accelerator more than normal to accelerate. This causes the tc to come on and without the normal amout of power to "push the truck" thru the shift, it will chuggle, bounce, bobble or what ever you want tocall it. Since you're haveing turbo problems, I would assume that's what's causeing it. Preston
ipz2222 is offline  
post #3 of 6 Old 03-16-2007, 01:05 PM Thread Starter
Powerstroke.org Rookie
 
fireballe21's Avatar
 
Join Date: Mar 2007
Location: Savannah, GA
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via Yahoo to fireballe21
Ipz, I think you hit it right on the head. I finally had the time today to check everything out real good and found that the linkage from the pedestal to the ebv ont the turbo had come off some how. Ebpv wasnt working or even being held back by anything causing it close partially. Hooked it back up and feels like a new truck. The chugging even went away. Thanks for the help.

early '99 (10/98) F350 SRW 4x4, CC, long bed, 7.3L, AFE stage II, Banks Six-Gun, MBRP 4", Zoo-Dad mod, DieselSite HX mod, Nitto Terra Graps 305/70/16, Custom built stock trans with roller bearings and billet T/C.
fireballe21 is offline  
post #4 of 6 Old 03-16-2007, 01:31 PM
BIG TRUCK, SMALL DRIVER
 
pipelayerjdh's Avatar
 
Join Date: Oct 2006
Location: Iva, SC
Posts: 5,877
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Have you checked the intercooler boots?

Derrick


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.




To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


'97 F-350 "FORDOR" 4X4 (Dually Conversion, Shackle Reversal, Technicooler , Auto Meter Gauges, 4" DIY Dual Exhaust w/ '08 tips,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, Wicked Wheel 2, 360 thrust bearing, Homemade E-fuel conversion, Wildman Chip,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
) 230K and counting...
pipelayerjdh is offline  
post #5 of 6 Old 03-16-2007, 04:28 PM Thread Starter
Powerstroke.org Rookie
 
fireballe21's Avatar
 
Join Date: Mar 2007
Location: Savannah, GA
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via Yahoo to fireballe21
Quote:
Originally Posted by pipelayerjdh View Post
Have you checked the intercooler boots?
Yea I checked them and found 1 very small leak, not really enough to cause the kind of non-performance that I was getting

early '99 (10/98) F350 SRW 4x4, CC, long bed, 7.3L, AFE stage II, Banks Six-Gun, MBRP 4", Zoo-Dad mod, DieselSite HX mod, Nitto Terra Graps 305/70/16, Custom built stock trans with roller bearings and billet T/C.
fireballe21 is offline  
post #6 of 6 Old 03-16-2007, 06:10 PM
Compression Ignition Addict
 
Join Date: Dec 2006
Posts: 1,256
Thanks: 0
Thanked 7 Times in 7 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
FANTASTICK!! preston
ipz2222 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome