Bad Injector? - Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 26 Old 10-09-2009, 08:11 AM Thread Starter
Powerstroke.org Fanatic
 
99red7.3's Avatar
 
Join Date: Aug 2009
Posts: 100
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Bad Injector?

Hey guys i got a 99 psd. It runs hard when i first start it but after it warms up it runs fine or if i plug it in for about 2 hours it does fine to. So i thought i need to replace the glow plugs so i did and also replaced the glow plug relay and still i have the same problem could this be a bad injector or injectors? Thanks for the help Evan


Born 4/99
4X4 6 Speed
05 Front Grill
PHP 6 Position Chip
MBRP 4" TB Exhaust
Foil Delete
DIY Intake
Wicked Wheel
Zoodad
5% Tint
Autometer Boost and Pyro Guages
99red7.3 is offline  
post #2 of 26 Old 10-09-2009, 08:27 AM
Living on a prayer
 
Join Date: Sep 2007
Location: Salem, Oregon
Posts: 291
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
starts rough

does it do it without the 10K mod in? do you run any fuel system cleaner (i.e seafoam through your fuel bowl), or biodiesel mix? that's about the limit of my "expertise". Maybe get it buzz tested along with a cylinder contribution test?

Early 99 (7/98) F-350 CC 4X4 AT 7.3L 200K mi - 4" turbo back w/muffler - AFE Stage 2 - PMT1 ECM - DP 40T/DECEL/80E - dual trans coolers - HPX - Fuel CCK - Auto Meter Trans/EGT/Boost - 3.73 - stock tires
samiam is offline  
post #3 of 26 Old 10-09-2009, 08:44 AM Thread Starter
Powerstroke.org Fanatic
 
99red7.3's Avatar
 
Join Date: Aug 2009
Posts: 100
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
yes it does it without the 10 k mod i just put that in and mines on a switch anyways. but i have ran seafoam throught the truck but just put it in the tank didnt put it straight to the fuel bowls.


Born 4/99
4X4 6 Speed
05 Front Grill
PHP 6 Position Chip
MBRP 4" TB Exhaust
Foil Delete
DIY Intake
Wicked Wheel
Zoodad
5% Tint
Autometer Boost and Pyro Guages
99red7.3 is offline  
post #4 of 26 Old 10-13-2009, 11:36 AM Thread Starter
Powerstroke.org Fanatic
 
99red7.3's Avatar
 
Join Date: Aug 2009
Posts: 100
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Anyone else have any ideas?


Born 4/99
4X4 6 Speed
05 Front Grill
PHP 6 Position Chip
MBRP 4" TB Exhaust
Foil Delete
DIY Intake
Wicked Wheel
Zoodad
5% Tint
Autometer Boost and Pyro Guages
99red7.3 is offline  
post #5 of 26 Old 10-13-2009, 12:30 PM
Compression Ignition Addict
 
strokin95style's Avatar
 
Join Date: Mar 2008
Posts: 644
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Ever run any ful injector cleaner through it? Could just be a dirty injector. Not quite sure, but it could possibly injector o-rings bad. How many miles on the truck?

Nater
1995 f-250 rclb
7.3~317k miles & countin
3" Downpipe
Superduty 10.5" 3 pinion Trac-Lok rear
Dana 60 s.a.s

1997 ccsb , 353,500 miles
5" lift on 315x75x16 cooper at3's.
Clear headlights, tinted tails, rear buckets,
Dana 60 swap, zf5 swap.
rosewood 180/100's, t500 hpop, php hydra, e fuel.
strokin95style is offline  
post #6 of 26 Old 10-13-2009, 07:13 PM Thread Starter
Powerstroke.org Fanatic
 
99red7.3's Avatar
 
Join Date: Aug 2009
Posts: 100
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Yea i just replaced the fuel filter this weekend and dumped a bottle of seamfoam in the tank still hasnt fixed the problem. and its getting to where its only wanting to start when i spray ether in the air filter until its to running temp then it runs and starts fine but its got around 217xxx miles


Born 4/99
4X4 6 Speed
05 Front Grill
PHP 6 Position Chip
MBRP 4" TB Exhaust
Foil Delete
DIY Intake
Wicked Wheel
Zoodad
5% Tint
Autometer Boost and Pyro Guages
99red7.3 is offline  
post #7 of 26 Old 10-13-2009, 07:20 PM
Premium Member
 
ryandamo's Avatar
 
Join Date: Jun 2009
Location: Connecticut
Posts: 1,205
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
glow plug realy might be shot?


2016 F450 6.7L XLT 4x4Dump, bone stock
1994 F250 7.3L XLT 4x4 ZF5 , Centurion, 4" Lift, 6637, Gulf Coast Bypass Filter, Big fuel tanks, dana 60 swap, No longer dually
1997 F350 7.3L XLT 4x4Dump, E4OD, 4 in exhaust, TS 6 position, 3/8 Trans line+external filter
2013 Scag Turf Tiger 61" 1.1L Caterpillar Diesel
1960 John Deere 440 Backhoe 2-53 detroit
ryandamo is offline  
post #8 of 26 Old 10-13-2009, 07:24 PM Thread Starter
Powerstroke.org Fanatic
 
99red7.3's Avatar
 
Join Date: Aug 2009
Posts: 100
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
idk how i just replaced it a month ago when i replaced my glow plugs but i kept the old one so im thinking of just switching them and see what happens im running out of ideas


Born 4/99
4X4 6 Speed
05 Front Grill
PHP 6 Position Chip
MBRP 4" TB Exhaust
Foil Delete
DIY Intake
Wicked Wheel
Zoodad
5% Tint
Autometer Boost and Pyro Guages
99red7.3 is offline  
post #9 of 26 Old 10-13-2009, 08:30 PM
Member
 
Join Date: May 2009
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
mine is doing the same thing only worse.. check your fuel pressure reg, do your injectors make alot of noise? mine are loud, way louder than my buddys 7.3 so im going to be changing out injectors next week..
GnArKiLL is offline  
post #10 of 26 Old 10-13-2009, 09:24 PM Thread Starter
Powerstroke.org Fanatic
 
99red7.3's Avatar
 
Join Date: Aug 2009
Posts: 100
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
ok i will what should it be reading like what do i need to check on it but damn man i hope my injectors arent going bad i dont got the extra money to drop for some


Born 4/99
4X4 6 Speed
05 Front Grill
PHP 6 Position Chip
MBRP 4" TB Exhaust
Foil Delete
DIY Intake
Wicked Wheel
Zoodad
5% Tint
Autometer Boost and Pyro Guages
99red7.3 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome