Problems with new 99 PSD. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-08-2009, 06:40 PM
Compression Ignition Addict
 

Join Date: Oct 2006
Location: conneticut
Posts: 217
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to SUPER60omni
Problems with new 99 PSD.

Ok, my friend just bought a early 99 F250 PSD with 180,000mi. When we went to look at it the motor was skipping pretty good but wasnt making any noise or smoking. After it ran for like a hour it kinda smoothed out but was still a dead miss when you hit the gas. I suspected bad injector(s). Ive never done a injector on a 7.3 but I own one myself so it was time to learn. So we bought it (cheap). I scanned it on a OTC Genisis scanner that Ive used before to buzz test a 7.3. When I scanned it I just got a few Exhaust back pressure codes and a low turbo boost code. So I cleaned out the tube to the EBP sensor and swapped the sensor with a known good one. Now on to the buzz test....... All 8 buzzed then in the test the 1st buzz was almost non existant and the next 7 sounded normal. So I was guessing Cyl #1 was our culprit injector. Also when I did a cylinder contribution/balance test cyl #1 AND 4 failed the test?

So today we robbed a injector out of another totalled 7.3 that we have that still runs perfect. We replaced in the new truck and after a while the idle skip cleaned up for the most part but when the throttle is applied you still feel it missing a cylinder. So my question is do you think its just another bad injector or mabey a bad IDM or a valve cover harness? We wiggled and unplugged the VC harness and nothing changed. I know some of these trucks had issues with loose plughs on the harness.......and on the new truck there is a white zip tie on the connector clip on the inside of the VC. Is that stock or was it a fix?

Anyone that has experience in this please help me out Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-09-2009, 06:32 AM
Compression Ignition Addict
 

Join Date: Oct 2006
Location: conneticut
Posts: 217
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to SUPER60omni
Anyone????
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:10 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors