1 out of 10, crank but no dashboard lights at all. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-21-2009, 04:01 PM
Powerstroke.org Rookie
 

Join Date: Sep 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
1 out of 10, crank but no dashboard lights at all.

Hi guys, I have been reading you for a couple of months now.

own a E350 1997

1 out of 10, crank but no dashboard lights at all. I mean no wts light, no warning lights at all. Then I try a couple times and more and then lights are cycling, wts is cycling normally and truck starts normally. The truck never dies while driving. I a little afraid because I will use this E350 1997 mostly in Canadian winter. brrrrrrrrrrrrrr

I have 2 brand new batteries, charging system ok, bought truck at 148000 miles

thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-21-2009, 04:59 PM
Compression Ignition Addict
 

Join Date: Apr 2008
Location: lodi
Posts: 346
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
id you cheack the fuses? lol
Reply With Quote Quick reply to this message
  #3  
Old 09-21-2009, 05:02 PM
Powerstroke.org Rookie
 

Join Date: Sep 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by mean97 View Post
id you cheack the fuses? lol
Can it be a fuse even if problem is intermittent 1 out of 10. thanks
Reply With Quote Quick reply to this message
  #4  
Old 09-21-2009, 05:34 PM
Compression Ignition Addict
 

Join Date: Apr 2008
Location: lodi
Posts: 346
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
well if you have no lights in the dash i would think its a fuse or relay id cheack them out if i was you. if not im sure we can find out the prob
Reply With Quote Quick reply to this message
  #5  
Old 09-22-2009, 05:43 PM
Powerstroke.org Rookie
 

Join Date: Sep 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Is it CPS related?
Reply With Quote Quick reply to this message
  #6  
Old 09-23-2009, 10:41 PM
Powerstroke.org Fanatic
 

Join Date: Feb 2008
Location: Klamath Falls,Oregon
Posts: 149
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Something electrical not CPS for sure.Probably something in your key tumbler steering column area
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:42 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors