I need some major help!!! - Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 56 Old 02-21-2007, 07:02 PM Thread Starter
Compression Ignition Addict
 
dukey_78's Avatar
 
Join Date: Dec 2006
Location: Carthage IL
Posts: 304
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I need some major help!!!

My 99 f250 is really stressin me out and i would really like some answers. Sometimes when i start the truck it will fire up then die it will only run with my foot on the go pedal then let off slow will idle, Then when driving down the road no power at all and the check engine lite flashes. other times go and start it up and idle real rough until i put a good load on it. when all this happens i can drive some where shut it off and go bs for a while and when i come back and start it will run like a dream. This all started after i put my edge evo on my truck not knowing it had a chip in it already... so i someone has ne good ideas i could really use them.....................................
dukey_78 is offline  
post #2 of 56 Old 02-21-2007, 11:50 PM
Premium Member
 
straycat's Avatar
 
Join Date: Nov 2006
Location: Surrey B.C. Canada
Posts: 4,507
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Hey Dukey, when that happened, didn't you end up replacing the PCM with a new one?

Gord.

SKILLFULLY DISGISED AS A RESPONSABLE ADULT.




99.5 F350, CC, LB, DRW.
7.3 AUTO 4.10s
AUTOMETER C2s EGT, TRANS, BOOST, OIL, FUEL PRES
ATS, WW, SSHPX, B ANNIH.
DP 6P 140EX.
AFE MAG F STG 2.
MAGNAFLOW 4'' TURBO BACK DUALS.
US GEAR SUPER D-CELERATOR
500LTR FUEL TANK
BILLET GRILL
ALARM & REM START/ ELC BAT DISC.
CB, SAT, GPS, PANASONIC CD, 5th WHL
35' GOLDEN FALCON

Been a mod longer than TJ hahaha
straycat is offline  
post #3 of 56 Old 02-22-2007, 12:32 AM
HardLuck Case of the Year
 
Ditty's Avatar
 
Join Date: Sep 2006
Location: Catonsville, MD
Posts: 3,541
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to Ditty Send a message via Yahoo to Ditty
Sounds like a possible clogged fuel filter...POSSIBLY. That, or low oil pressure. Check your fuel filter, check your oil....other than that, I dunno.


DITTY

Brisco:-White 2000 F-350 PSD CrewCab/SRW/LongBed/4x4/6spd Manual/HUGE Powerstroke.Org Vinals!

Favorite Mods: Baby-seat mod/Girlfriend delete/6pos on Xtreme!

Repairs since bought: both batteries/alternator/3 transmissions/4 clutches/entire front axle/new steering stabilizer/power steering pump

Still broken: cracked windshield/all glowplugs/glowplug relay/4WD still out/trailer harness no power

Current Best: 16.149@84.13MPH (Est.7800lbs)
Ditty is offline  
post #4 of 56 Old 02-22-2007, 04:24 AM
Member
 
Join Date: Feb 2007
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
it may be the fuel filters in the mixing chamber in the tank. Very common problem, just cleaned mine out 1 month ago. Drop the tank and check out the filters.
Bronconut is offline  
post #5 of 56 Old 02-22-2007, 04:39 AM
duct tape & zip ties

 
bigcountrysg's Avatar
 
Join Date: Jul 2006
Location: Willis, MI
Posts: 10,761
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via Yahoo to bigcountrysg
Could be CPS, low oil level, in need of oil change, clogged fuel filter, fuel pump going out, PCM bad, Throttle Positioning sensor. You said you installed your edge evo on the truck and didn't know that it already had a chip. Have you tried running the truck with everything removed. As in remove the chip, remove edge evo and see how the truck runs. The way it sounds your truck is not liking the edge evo. I would put it back to stock see how it runs then install either the chip or the edge evo. Don't install both then see how it runs. The two programs maybe conflicting with eachother. You may need to get the pcm reflashed.

You said that the engine light flashes, can you pull any codes. Usually if the engine light comes on it is catchinig a code from some where. If you can plug in a scanner tool and see what codes you get then post them and maybe we can figure this out and narrow down your problem.


Your Actions Today, Decide Your Future Tomorrow

2005 6.0 Crew Cab Long Box Lariat, current truck

2004 6.0 destroyed by contaminated fuel

2002 7.3L burnt

Last edited by bigcountrysg; 02-22-2007 at 04:42 AM.
bigcountrysg is offline  
post #6 of 56 Old 02-22-2007, 03:49 PM Thread Starter
Compression Ignition Addict
 
dukey_78's Avatar
 
Join Date: Dec 2006
Location: Carthage IL
Posts: 304
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
OK i just changed my oil and fuel filter 2 weeks ago i am running it on stock nothing on it and it is doin the same thing as before. i checked codes one of them was injector pressure above or below desired that is only when it is running bad let the truck for a while and then runs awesome no codes either.
dukey_78 is offline  
post #7 of 56 Old 02-22-2007, 04:24 PM
Jon
Guest
 
Posts: n/a
Mentioned: Post(s)
Quoted: Post(s)
Icp

I had a truck last week do this exact same thing. Funny thing with these is that doesnt meen its the same problem. Monitor your ICP and see where it is at. I put an ICP sensor in and it fixed it. Try disconnecting your ICP and starting it also.
post #8 of 56 Old 02-22-2007, 04:59 PM
Compression Ignition Addict
 
House22's Avatar
 
Join Date: Nov 2006
Location: Kokomo, In
Posts: 402
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to House22
its a 7.3 boys you cant stack, if theres a chip in the ecm the chip will over ride the flash or tuner, if its a flasehd ecm and put a programer on it the programer will over ride the ecm


things to check, hpop oil level, hpop pressure idling and driving, icp connctor make sure its clean and not burnt, clean the ipr, buzz test, and contrubtion test, fuel pressure check, then possibly check the under valve cover harness's too

2000 F350 Crew Cab Dually Larait all options
zf6 6 speed
SBC 4200 Full Fermaic DD Clutch
Custom Tunning by Swamps
Swamps 355 Injs
Itp Diesel Reg Return, Hi Po Delivery Kit
Aeromotive a1000 fuel pump
BTS Twin HPOP, Arp Head Studs, Di Pushrods, Comp 910's, Fluid Damper
Hypermax Mount Turbo Mount
S476 By Swamps BFH-HE
One piece rear drive shaft by haisley machine
Ntpa certifed Drive line shields done by Haisley machine
www.hoosiertruckclub.com
House22 is offline  
post #9 of 56 Old 02-22-2007, 07:41 PM Thread Starter
Compression Ignition Addict
 
dukey_78's Avatar
 
Join Date: Dec 2006
Location: Carthage IL
Posts: 304
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
My comp is getting flashed on saturday. then i will go from there i really hope this will fix it but if not i will keep on trucking and find out wat is goin on with it. I won't be out ne thing but the fuel to drive about 30 miles my cuz is a tech and is doin it for me.
dukey_78 is offline  
post #10 of 56 Old 02-22-2007, 07:48 PM
Powerstroke.org Rookie
 
maxdout1's Avatar
 
Join Date: Feb 2007
Location: Bridgewater Virginia
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
do yourself a favor and drive a duramax you will love it

02 chevrolet 2500hd D/A ccsd
maxdout1 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome