Radio dies if in Drive... - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 01-07-2009, 04:50 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: May 2008
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Radio dies if in Drive...

Hey guys,

I've got an 01 Excursion with the 7.3 in it. Well the other night we got a good amount of rain where I live. There must be a leak up over the drivers side front window, I got water on the floor boards near the kick panel. Well the truck acted up until the water dried. I still have 1 problem, the radio shuts off as soon as the truck is placed in any gear but park and neutral. The radio come rite back as soon as the trans is put in park or neutral. Does anyone know where I need to start to fix this?

Thanks,
Rich

My Garage....

2001 SVT Lightning
Sniper Tuned
PT76GTSH turbocharged 593/645 @15psi
11.61@123 1/4 with a neck snapping 2.04 60ft.
New dyno #'s 700/721 with no track time.

2001 7.3 PSD Excursion Limited
Sniper Tuned
Silverline 4" Turboback exhaust
DIY intake
ISSPRO gauges

2001 Pontiac GTP
Bolt on mods only
13.7 @ 103 best to date in the 1/4
white01 is offline  
post #2 of 2 Old 01-07-2009, 07:33 PM
Mod Newbie

 
dhanna6powerstroke's Avatar
 
Join Date: Feb 2008
Location: Bloomington, IN.
Posts: 13,144
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Thanks: 6
Thanked 141 Times in 133 Posts
Feedback Score: 2 reviews
Quote:
Originally Posted by white01 View Post
Hey guys,

I've got an 01 Excursion with the 7.3 in it. Well the other night we got a good amount of rain where I live. There must be a leak up over the drivers side front window, I got water on the floor boards near the kick panel. Well the truck acted up until the water dried. I still have 1 problem, the radio shuts off as soon as the truck is placed in any gear but park and neutral. The radio come rite back as soon as the trans is put in park or neutral. Does anyone know where I need to start to fix this?

Thanks,
Rich
I would get the front windshield checked for leaks. Probably leaking onto the fuse box. They had some problems with the Super Duty trucks and the Excursions. The water has shorted something out, but not sure why it only does it when in gear.

dhanna6powerstroke is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome