Have a few problems that need fixed - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-29-2012, 04:57 AM
Member
 

Join Date: May 2010
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Have a few problems that need fixed

I've been letting the little problems build up over the past few years, I need to catch this stuff before the truck turns into a complete POS. Any and all advice is appreciated. Truck is an early 99 F-350 dually 4x4.

1. Passenger side window not working. I replaced the switch about an hour ago, now I have up but not down on the passenger switch, nothing from the drivers side.

2. Speedometer quit a few months ago, not a clue there. It was acting funny for a while, sometimes not working, now I have nothing.

3. Heat controls quit, both the temp settings and the selector to tell it where to get air from. I believe this is a vacuum issue? Any ideas on where to start tracing the lines from?

Thanks for the help, I need to get this truck sorted out.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-29-2012, 04:59 AM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,037
Thanks: 0
Thanked 12 Times in 12 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by jules083 View Post
I've been letting the little problems build up over the past few years, I need to catch this stuff before the truck turns into a complete POS. Any and all advice is appreciated. Truck is an early 99 F-350 dually 4x4.

1. Passenger side window not working. I replaced the switch about an hour ago, now I have up but not down on the passenger switch, nothing from the drivers side.

2. Speedometer quit a few months ago, not a clue there. It was acting funny for a while, sometimes not working, now I have nothing.

Possibly a speed sensor? Idr where it is

3. Heat controls quit, both the temp settings and the selector to tell it where to get air from. I believe this is a vacuum issue? Any ideas on where to start tracing the lines from?

I'd check the vacuum pump. On top of passenger side fender.

Thanks for the help, I need to get this truck sorted out.
Replied to what I could

I made my Samsung SGH-I997 send this.
Reply With Quote Quick reply to this message
  #3  
Old 07-29-2012, 05:05 AM
Member
 

Join Date: May 2010
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by jesilvas View Post
Replied to what I could

I made my Samsung SGH-I997 send this.
Thanks. I went to auto zone for a speed sensor, they didn't know where it was either. There was a few of them listed, not a clue which one I have or where any of them are.

Vacuum pump is a good idea to check. Guess I'll start there and begin tracing lines. I read on here somewhere that the heat controls and the front hubs run the same line, but there's nothing going to my hubs so I'm thinking that was either ripped out or blocked off somewhere along the line.
Reply With Quote Quick reply to this message
  #4  
Old 07-29-2012, 05:30 AM
Member
 

Join Date: May 2010
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok, looked at some stuff and realized a few things.

Window still doesn't work. Put a volt meter on it, there's power coming to some wires, but I'm not sure which ones should have power?

I think I figured out the speed sensor, a new one is $22 so I'll just change it and see what happens.

vacuum pump. Umm... I have one, what's it supposed to do? I turn the key to on and nothing happens, there's no power going to it. Does something tell it when to turn on, or maybe something in the wiring is bad?
Reply With Quote Quick reply to this message
  #5  
Old 07-29-2012, 06:12 AM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,037
Thanks: 0
Thanked 12 Times in 12 Posts
Feedback Score: 0 reviews
You should here the pump buzzing

I made my Samsung SGH-I997 send this.
Reply With Quote Quick reply to this message
  #6  
Old 07-29-2012, 07:28 AM
Member
 

Join Date: May 2010
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by jesilvas View Post
You should here the pump buzzing

I made my Samsung SGH-I997 send this.
Nothing. No buzzing, I unhooked a vacuum line and nothing happened, no power going to it, no blown fuses.

Any ideas?
Reply With Quote Quick reply to this message
  #7  
Old 07-29-2012, 04:55 PM
Member
 

Join Date: May 2010
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Still no ideas?
Reply With Quote Quick reply to this message
  #8  
Old 07-29-2012, 05:29 PM
Guns & Powerstroke's
 

Join Date: Apr 2009
Location: North Central Oklahoma
Posts: 258
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Does it blow out defrost all the time?
Reply With Quote Quick reply to this message
  #9  
Old 07-29-2012, 06:04 PM
Member
 

Join Date: May 2010
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by HillClimber350 View Post
Does it blow out defrost all the time?
Yes, and it's also on cold all of the time.

Last year I was able to adjust temperature, but not that doesn't work either. The heater core is working properly, and I am able to manually move the temperature selector from behind the dash and get heat to come out.
Reply With Quote Quick reply to this message
  #10  
Old 07-29-2012, 07:46 PM
Guns & Powerstroke's
 

Join Date: Apr 2009
Location: North Central Oklahoma
Posts: 258
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
All of those are ran by vacuum pump.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:23 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors