multiple small annoying issues - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-20-2012, 12:16 PM
Member
 

Join Date: Mar 2012
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
multiple small annoying issues

Alright ladies and gentleman, let me start off with i bought this truck not running, totalled, and took much more of a risk than I realized. (Was all excited in the moment, now that i own it, not so much glory in it) Its a 2002 CCLB 7.3/Auto/4x4 with 168k

First problem i noticed is the annoying door ajar light issue. Well I am not one to create a thread asking something that has been gone over about 58743623238957 times, so i did a search.

Door Ajar Switch?

according to the above thread, along with about 2948953577839493 others, just spraying some WD40 would fix this issue. Great!! I love free fixes!! Only this wasn't the case for me. marinated the latches, slammed the doors about 15-20 times each, lubed again, slammed 5 more times. Still has the light...


Well, the only lights on the interior of the truck are the little red lights at the bottom of the doors and the dash lights. Why, I have no idea. I haven't checked to see if the dome light is in there, or hooked up, or working. I have been focused on getting it running.

Then there is the problem that happened today (I have only had this thing running for 2 days). When I start the truck, my window switches and radio don't work. Nothing. Its like the truck still thinks it is off. So i get back on here, and start searching. Come to find out I was not the only one to have this issue.

Radio and windows dont work

But if you notice, that is in the 6ho forum. I know that the sheet metal and a few other components of the truck is the same throughout the life span of these, but i don't know if anyone else with a late 99-04 have had this issue as well.

From what i could gather from the 6.0 thread is that the problem is resulting from the GEM or the Instrument Cluster, which seems to control almost all of the interior things.



Now that you guys know that i did do some searching before asking the same questions 12930294783 times, could all this junk be related? Is it worth going through replacing door latch switches (Which i cannot seem to find anywhere), when i have an even bigger problem that lies within the Instrument Cluster or GEM? Am i just over thinking this?

Thanks to anyone and everyone who can offer up some advice/help
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-22-2012, 12:19 PM
Compression Ignition Addict
 

Join Date: Nov 2010
Location: Southern Idaho
Posts: 256
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have a same small issue like the dome light stays on, but I just take it out.

As for the GEM, I have read that if it gets to wet stuff will randomly go haywire. I would really start there but I think they can be spendy and good luck with finding a good used one to. Seems like those are the first to be stripped out.
Reply With Quote Quick reply to this message
  #3  
Old 05-01-2012, 03:16 PM
Member
 

Join Date: Feb 2011
Location: Crownsville, MD
Posts: 74
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have an 02 7.2 ext.cab LB and when its hot outside i have the same problem with my window switches and radio+clock doesn't work but its only when i first start my truck and it lasts about 2-3 min and then everything goes back to normal haven't looked into it but i have no idea about what could cause it except that it only does it when its hot
Reply With Quote Quick reply to this message
  #4  
Old 05-01-2012, 07:51 PM
Member
 

Join Date: Mar 2012
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
same thing here. From what i have gathered, it is regarding the instrument cluster or GEM module. Each are hundreds....
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:16 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors