Need help ASAP horn honking - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 10-26-2010, 03:16 PM Thread Starter
Compression Ignition Addict
 
Join Date: May 2007
Posts: 170
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Feedback Score: 0 reviews
Need help ASAP horn honking

My horn is honking on its own. I was inside and my horn starts honking, i go out unlock the door and when I opened the door it stopped honking. I go back in and started doing it again. When I open the door it stops everytime. Its been doing this for the past 4 hours. anyone ever had this problem? Its a 99. No alarm system. No keypad. No key fob. I cant imagine this happening when im hunting.

Also it rained like crazy here today
Builttuff is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 10-26-2010, 03:54 PM
Compression Ignition Addict
 
cbubac's Avatar
 
Join Date: Oct 2009
Location: Raleigh, Norte Carolina
Posts: 171
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Clockspring? did you replace any steering components lately, If you cant figure it out pull the horn fuse as a temp fix

Thanks... Corey

03 7.3, 4" exhaust w/FTE Stack, DPTUNER, AFEII, Roll of Duct Tape, and a few other goodies

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

It sounds like bigfoot farting in a large trash can for a very long time!
cbubac is offline  
post #3 of 4 Old 10-26-2010, 04:17 PM Thread Starter
Compression Ignition Addict
 
Join Date: May 2007
Posts: 170
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by cbubac View Post
Clockspring? did you replace any steering components lately, If you cant figure it out pull the horn fuse as a temp fix
I pulled the fuse. havent done any work to truck in months. buddy said maybe the switch in the door latch is bad or wet? I dont know!
Builttuff is offline  
post #4 of 4 Old 10-26-2010, 06:12 PM Thread Starter
Compression Ignition Addict
 
Join Date: May 2007
Posts: 170
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Feedback Score: 0 reviews
I pulled the fuse block down and looked at the back of GEM and didnt see any moisture or any water marks? Anybody have any ideas?
Builttuff is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome