uh oh!! Please help - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-22-2009, 06:08 AM
Compression Ignition Addict
 

Join Date: Sep 2006
Location: Mass
Posts: 232
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
uh oh!! Please help

So i have a connecting rod sticking through my oil pan. Reman Ford 7.3 has 50,000 miles on it. Oil changes every 3000-4000 miles, minimum mods. Exhaust Chip and intake. I dont think I snapped the rod I think its the main bearing went and it snapped the two cap bolts. I had a warranty on the engine that expired a year ago. If I pull the chip and load my factory settings that i saved on my Diablo back onto the truck will it erase any traces of the chip??? What do you guys think my chances of getting ford to replace or repair my problem....there is no reason this should happen if i had crazy mods done on my truck i could understand but just the DP an exhaust and an intake, i shouldnt be any where near the amoubnt of HP it would take to snap a Rod should I?????

BTW I was idleing in a parking lot when this happend
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-22-2009, 06:15 AM
wriott
Guest
 
Posts: n/a
unless you have a warrenty on the truck i think you might be SOL
Reply With Quote Quick reply to this message
  #3  
Old 06-22-2009, 06:52 AM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Burlington, NC
Posts: 999
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to nccatfan
If the cylinder and crankshaft journal look unblemished I'd give it a new piston/rod and oil pan and keep truckin! Check torque on the other cap bolts too. Couldn't hurt to look at the other bearings while you're at it.
Reply With Quote Quick reply to this message
  #4  
Old 06-22-2009, 06:56 AM
duct tape & zip ties

 

Join Date: Jul 2006
Location: Willis, MI
Posts: 10,759
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to bigcountrysg
Quote:
Originally Posted by joelucci33 View Post
So i have a connecting rod sticking through my oil pan. Reman Ford 7.3 has 50,000 miles on it. Oil changes every 3000-4000 miles, minimum mods. Exhaust Chip and intake. I dont think I snapped the rod I think its the main bearing went and it snapped the two cap bolts. I had a warranty on the engine that expired a year ago. If I pull the chip and load my factory settings that i saved on my Diablo back onto the truck will it erase any traces of the chip??? What do you guys think my chances of getting ford to replace or repair my problem....there is no reason this should happen if i had crazy mods done on my truck i could understand but just the DP an exhaust and an intake, i shouldnt be any where near the amoubnt of HP it would take to snap a Rod should I?????

BTW I was idleing in a parking lot when this happend
Warranty expired last year, was that the reman engine warranty. Or was that the warranty on the truck.

What type of warranty is on the reman engine.
Reply With Quote Quick reply to this message
  #5  
Old 06-22-2009, 07:12 AM
Banned
 

Join Date: Dec 2008
Posts: 2,850
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Even if your waranty only expired last year I don't think that Ford will help you out. Good luck getting it fixed though!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:01 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors