need help!!! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-25-2009, 06:04 AM
Powerstroke.org Rookie
 

Join Date: Jan 2008
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
need help!!!

I bought a tw chip and installed and nothing happened its still stock and i clean the board and everything nothing. so i was wondering if yall had any ideas?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-25-2009, 06:42 AM
Compression Ignition Addict
 

Join Date: Feb 2008
Location: Foley, Minnesota
Posts: 433
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Clean the board better. Ps love love the screen name. LOL
Reply With Quote Quick reply to this message
  #3  
Old 04-25-2009, 06:46 AM
Powerstroke.org Rookie
 

Join Date: Jan 2008
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ya thanks i just bought some scoth bright
Reply With Quote Quick reply to this message
  #4  
Old 04-25-2009, 06:48 AM
Bird is the Word

 
Join Date: Apr 2008
Location: West Lafayette, in
Posts: 5,442
Thanks: 0
Thanked 11 Times in 11 Posts
Feedback Score: 0 reviews
clean the connection good, but don't clean it to much because then it won't work right ( just find a happy medium, and you'll know if its too clean or not)
Reply With Quote Quick reply to this message
  #5  
Old 04-25-2009, 02:45 PM
Powerstroke.org Rookie
 

Join Date: Jan 2008
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
its workin i love it but i just got questions about it now because exteme and street seem the same and in between gear the turbo blows off, i was wondering if yalls do that?
Reply With Quote Quick reply to this message
  #6  
Old 04-25-2009, 11:33 PM
Powerstroke.org Sponsor

 

Join Date: Oct 2006
Location: Ventura County, CA
Posts: 20,361
Thanks: 23
Thanked 23 Times in 14 Posts
Feedback Score: 2 reviews
Send a message via AIM to Raul@Stealth Automotive
the blow off is normal... all the built up pressure has to go somewhere...

do you have gauges?
Reply With Quote Quick reply to this message
  #7  
Old 04-26-2009, 07:04 AM
Powerstroke.org Rookie
 

Join Date: Jan 2008
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
no not yet im workin on that
Reply With Quote Quick reply to this message
  #8  
Old 04-28-2009, 02:54 PM
Powerstroke.org Rookie
 

Join Date: Jan 2008
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
whats the return policies on this chip?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:44 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors