Bad TW Switch? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-09-2009, 05:17 PM
Member
 

Join Date: May 2007
Posts: 63
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Bad TW Switch?

I had the craziest thing happen on the way home tonight and I am not a happy camper. As I was merging onto the highway, I turned my TW-6 chip from position 2 (ECON) to position 4 (STREET/STRIP) and the truck almost shut down! I floored it and the truck would not accelerate and she was rolling coal like a locomotive. I tried turning the switch to all positions while still on the accelerator, and the SES light came on.

After 1/4 mile, she just dies and stalls out. Luckily, I could coast to the median and stop...Just to see 2 State Troopers come up behind me...After 45 minutes of explaining why my truck has passenger plates, yes it is chipped but I was not in the smoke setting or "exibition of power"... they let me go.

I turn the key, she fire right up, no SES light and I drive 27 miles home with no problems. I know this is a long thread, but WTF happened?

Bad switch?

Solar Flares?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-09-2009, 05:50 PM
Powerstroke.org Rookie
 

Join Date: Mar 2009
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
iv got the tw chip and when I turn from economy to daily...the truck allways dies...but allways starts right back up
Reply With Quote Quick reply to this message
  #3  
Old 04-09-2009, 07:06 PM
Compression Ignition Addict
 

Join Date: Dec 2007
Location: Ocala, Fl
Posts: 1,428
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Send a message via AIM to no-tel-in
hah, dairyfarmer? me too!
Reply With Quote Quick reply to this message
  #4  
Old 04-09-2009, 07:31 PM
Member
 

Join Date: Feb 2009
Location: Athens, TN
Posts: 89
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by no-tel-in View Post
hah, dairyfarmer? me too!
Me three mine always dies too going from econ to daily i just make sure I stop before switching it.
Reply With Quote Quick reply to this message
  #5  
Old 04-10-2009, 07:39 AM
Powerstroke.org Fanatic
 

Join Date: Aug 2008
Posts: 105
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
mine dies going econo to stock
Reply With Quote Quick reply to this message
  #6  
Old 04-10-2009, 10:52 AM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Manchester,CT
Posts: 260
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mine dies from Econ-Tow but it always starts back up also. I always make sure to stop and I have enough time to start her back up again.
Reply With Quote Quick reply to this message
  #7  
Old 04-10-2009, 02:09 PM
Compression Ignition Addict
 

Join Date: Jan 2007
Location: Springfield, OR
Posts: 738
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
let off the accelerator before switching tunes
Reply With Quote Quick reply to this message
  #8  
Old 04-10-2009, 02:19 PM
Compression Ignition Addict
 

Join Date: Dec 2006
Location: Georgetown, Ky
Posts: 393
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mine does good turning to the right (stock-extreme) but not so good to left.
Reply With Quote Quick reply to this message
  #9  
Old 04-10-2009, 02:23 PM
Compression Ignition Addict
 

Join Date: Nov 2007
Location: New Riegel, Ohio
Posts: 5,229
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Mine turns between all the tunes fine and never dies. Always let out of the accelerator before changing tunes.
Reply With Quote Quick reply to this message
  #10  
Old 04-10-2009, 02:25 PM
I am that hot

 

Join Date: Sep 2008
Location: Flemington NJ
Posts: 1,762
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to superxcrewfx4 Send a message via Yahoo to superxcrewfx4
Mine did it once, I figure it is normal, like any computer switching programs while driving has to confuse something somewhere. Mine started right up as well.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:39 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors