Troubleshooting Gauges - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-10-2014, 11:17 AM
Serving Our Country!

 

Join Date: Sep 2012
Posts: 411
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Troubleshooting Gauges

I tried searching but couldn't find anything similar to my issue. I have ISSPRO EGT Boost and Trans temp gauges on my 2001 7.3 and have a few problems.
The EGT gauge quit on me bit for a while after it would react extremely slowly and I have no idea as to the accuracy. I did pull the probe and clean it and it reacted slowly for awhile then quit again.
The Trans Temp gauge likes to freak out and the needle does all kinds of weird motions. I verified through my monitor that that the trans didn't blow up when it did it the first time.
Can anybody point me in the right direction as to where to start? I'm mot an electrical guru so I don't know if I should look at the gauge, probe, wiring, etc........


Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-10-2014, 02:26 PM
Compression Ignition Addict
 

Join Date: Oct 2006
Location: Bend, Or
Posts: 6,089
Thanks: 29
Thanked 38 Times in 36 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by USMC2001PSD7.3 View Post
I tried searching but couldn't find anything similar to my issue. I have ISSPRO EGT Boost and Trans temp gauges on my 2001 7.3 and have a few problems.
The EGT gauge quit on me bit for a while after it would react extremely slowly and I have no idea as to the accuracy. I did pull the probe and clean it and it reacted slowly for awhile then quit again.
The Trans Temp gauge likes to freak out and the needle does all kinds of weird motions. I verified through my monitor that that the trans didn't blow up when it did it the first time.
Can anybody point me in the right direction as to where to start? I'm mot an electrical guru so I don't know if I should look at the gauge, probe, wiring, etc........


Sent from AutoGuide.com Free App
What version of gauges do you have? Are they EV, EV2 or Performax?
Reply With Quote Quick reply to this message
  #3  
Old 07-10-2014, 03:25 PM
Serving Our Country!

 

Join Date: Sep 2012
Posts: 411
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Troubleshooting Gauges

Performax. Had a pic somewhere but cant find it.


Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #4  
Old 07-10-2014, 07:02 PM
Compression Ignition Addict
 

Join Date: Oct 2008
Location: Abbotsford
Posts: 2,205
Thanks: 16
Thanked 86 Times in 79 Posts
Feedback Score: 0 reviews
I'm sure Joe will provide better insight, but I would start by making sure you have clean, solid grounds.
Reply With Quote Quick reply to this message
  #5  
Old 07-10-2014, 07:04 PM
Serving Our Country!

 

Join Date: Sep 2012
Posts: 411
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Good to go thanks guys. Sometimes the trans temp works fine other times it freaks. I definitely want them working again soon. Ill start digging when I get home and give you guys more info


Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #6  
Old 07-10-2014, 07:14 PM
Compression Ignition Addict
 

Join Date: Dec 2006
Location: Flowery Branch, GA
Posts: 1,316
Thanks: 15
Thanked 43 Times in 40 Posts
Feedback Score: 0 reviews
Do you have the right gauges hooked up?? I had mine reversed the first time after that they worked fine.

Just an idea
Reply With Quote Quick reply to this message
  #7  
Old 07-10-2014, 08:17 PM
Serving Our Country!

 

Join Date: Sep 2012
Posts: 411
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Hahaha yea I do they worked great for a long time somethin has just gone wacko. What exactly did they do when you had them hooked up wrong?


Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #8  
Old 07-11-2014, 05:51 PM
Compression Ignition Addict
 

Join Date: Dec 2006
Location: Flowery Branch, GA
Posts: 1,316
Thanks: 15
Thanked 43 Times in 40 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by USMC2001PSD7.3 View Post
Hahaha yea I do they worked great for a long time somethin has just gone wacko. What exactly did they do when you had them hooked up wrong?


Sent from AutoGuide.com Free App
The EGT moved really slow and the transmission never moved
Reply With Quote Quick reply to this message
  #9  
Old 07-11-2014, 06:09 PM
Serving Our Country!

 

Join Date: Sep 2012
Posts: 411
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Haha thats funny. Thankfully my trans temp moves and is accurate sometimes but other times it goes ballistic.


Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #10  
Old 07-14-2014, 03:09 PM
Compression Ignition Addict
 

Join Date: Oct 2006
Location: Bend, Or
Posts: 6,089
Thanks: 29
Thanked 38 Times in 36 Posts
Feedback Score: 0 reviews
To confirm you have PERFORMAX gauges, with a computer box mounted under the hood?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:06 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors