Help! LiveWire on 7.3 problems - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-22-2008, 06:13 PM
Premium Member
 

Join Date: Sep 2008
Posts: 148
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Help! LiveWire on 7.3 problems

H E L P!!! I just got a new livewire and have it set to street specs. I am getting 2 codes from it. po603, and po470. what do they mean. plus my trans feels like it is slipping from first to second and feels like it is popping from second to third. any suggestions. I have a 2000 with 7.3 powerstroke
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-22-2008, 06:22 PM
Powerstroke.org Sponsor

 

Join Date: Oct 2006
Location: Ventura County, CA
Posts: 20,355
Thanks: 23
Thanked 23 Times in 14 Posts
Feedback Score: 2 reviews
Send a message via AIM to Raul@Stealth Automotive
Quote:
Originally Posted by jared1 View Post
H E L P!!! I just got a new livewire and have it set to street specs. I am getting 2 codes from it. po603, and po470. what do they mean. plus my trans feels like it is slipping from first to second and feels like it is popping from second to third. any suggestions. I have a 2000 with 7.3 powerstroke
whos tunes are you running?
Reply With Quote Quick reply to this message
  #3  
Old 09-22-2008, 06:33 PM
Premium Member
 

Join Date: Sep 2008
Posts: 148
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Im running the preloaded street and performance tunes from SCT. I havent made any changes, just hooked it up and running their preloaded setups.
Reply With Quote Quick reply to this message
  #4  
Old 09-23-2008, 03:36 AM
Powerstroke Junkie


 

Join Date: Aug 2006
Location: Mayberry, NC
Posts: 8,309
Thanks: 0
Thanked 37 Times in 9 Posts
Feedback Score: 0 reviews
Those codes could have been in there for years!! Clear them and see what if any codes return? The 603 is the cam position sensor. Have you ever had one go out? If so that is the code from when it did. The 0470 code is the exhaust back pressure valve, could just be carbon build up or it could be a bad sensor. I cleaned mine three times before it finally went. Get the part from IH it is much cheaper!!

NCH
Reply With Quote Quick reply to this message
  #5  
Old 09-23-2008, 06:38 AM
Premium Member
 

Join Date: Sep 2008
Posts: 148
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
thanks I will try that with the back pressure sensor. anyone heard anything about these tunes from five star tuning. are they reputable, and are the tunes good. plus I have never had a cam shaft problem
Reply With Quote Quick reply to this message
  #6  
Old 09-28-2008, 06:57 PM
Compression Ignition Addict
 

Join Date: Feb 2008
Location: Colorado
Posts: 613
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I've never heard of five star tunes. There are a few places I have found that custom tune the livewire, I went with Elite because it was a friend of a friend deal. I can tell you that the pre-loaded tunes are nothing compared to the custom tunes you can get.
Reply With Quote Quick reply to this message
  #7  
Old 09-29-2008, 02:18 AM
Premium Member
 

Join Date: Sep 2008
Posts: 148
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by FordCowboy View Post
I've never heard of five star tunes. There are a few places I have found that custom tune the livewire, I went with Elite because it was a friend of a friend deal. I can tell you that the pre-loaded tunes are nothing compared to the custom tunes you can get.

does elite have a website that you can go to and check out their tunes offered
Reply With Quote Quick reply to this message
  #8  
Old 09-29-2008, 04:37 AM
Compression Ignition Addict
 

Join Date: Feb 2008
Location: Colorado
Posts: 613
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Welcome to Elite Diesel Engineering i believe
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:16 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors